Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher failed to initialize.

STAR WARS: The Old Republic > English > Customer Service
Launcher failed to initialize.
First BioWare Post First BioWare Post

iminik's Avatar


iminik
12.26.2011 , 07:25 PM | #1
After i hit enter to log into the game i get this message. The application failed to initialize properly (0x0150002). Can someone help.

Xexile's Avatar


Xexile
08.03.2012 , 11:26 AM | #2
i am having problem w the launcher the below message appears after i press the play button
.. my install was working fine except i was getting the dreaded blue screen 3 or 4 times during game play and i decided that cant be healthy for my machine ... copied my install to an empty drive that i use for back ups and things
reinstalled windows after i installed XP SP3 and copy and pasted back to C:\Program Files\Electronic Arts\
it original DIR and ran the repair launcher in side the EA folder
i had read in the forms how this worked for ppl and i also there are a ton of issues w moving the install ..
i just got done re downloading the install 2 days ago just before i started getting blue screens
PLZ don't try to tell me i have to re download everything at 3mbs
its like a 3 day download
aside from that message every thing looks good graphics are up to date SP's any suggestions ??
The application failed to initialize properly (0xc0150002) click ok to terminate the app

Tirvaak's Avatar


Tirvaak
08.03.2012 , 12:02 PM | #3 Click here to go to the next staff post in this thread. Next  
Hi guys,

This error generally refers to a problem with the .NET framework that is currently installed on your system. I would recommend to download and install the latest redistributable packs to help with this issue. The links for the downloads can be found in the spoiler below:

Spoiler


Once you have installed these please restart your system and then try to launcher the game again.

Please let me know if this helps.

Tirvaak | Bioware Customer Service - Forum Support

Xexile's Avatar


Xexile
08.03.2012 , 11:14 PM | #4
installed Net framework 4 and am pretty sure i didn't have it installed after the sp3 update last night
shut down my computer restarted it ran the fix launcher .. same message

maybe tomorrow i will upgrade to vista i will try to copy an paste it to the same DIR but i have a feeling i wont log in till Monday

thanks GOLD for your advice

Xexile's Avatar


Xexile
08.05.2012 , 09:53 AM | #5
okay im going to CRY
the fresh install finished this morning at 5am tried to log in same stupid message .

i just now uninstalled frame work 3 and 4 and reinstalled them rebooted :cry:
nothing same message i missing something besides the framework that would prevent the game from launching?
after a fresh install ?

1 hour later ... uninstalled graphics card reinstalled installed any pending updates from windows .. same

going to go outside and play i cant spend all day inside LF suggestions

Xexile's Avatar


Xexile
08.05.2012 , 11:09 AM | #6
Okay this fixed it i installed quick time i had zero media player video codecs installed on my machine

Quote: Originally Posted by Packetdancer View Post
Install the latest version of Quicktime from Apple's website, and that should fix the error. It seems that SWTOR doesn't handle a missing or outdated version of Quicktime gracefully when trying to play a cinematic.
TY Packetdancer and forms !

Bronholz's Avatar


Bronholz
08.05.2012 , 11:29 AM | #7 This is the last staff post in this thread.  
Greetings Xexile,

We're glad to hear that you were able to resolve the issue you were encountering.

If you require any further assistance please don't hesitate to contact us again.

Thanks.

iminik,

Are you still encountering this issue?

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support