Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Taris Bonus series (Republic) disappeared after 4.0 update?

STAR WARS: The Old Republic > English > General Discussion
Taris Bonus series (Republic) disappeared after 4.0 update?

Lord_Draevan's Avatar


Lord_Draevan
10.20.2015 , 07:25 PM | #1
I logged off last night with my character (lvl 26) on Taris, standing right in front of Strom, the Taris Bonus series quest giver. I had to log off so I didn't pick it up just yet, but the little triangle was hovering over his head. So I come back today after getting the 4.0 update... and I can't get the Bonus series from him anymore. No more triangle hovering over his head. I click him, only get a generic greeting. I check all the outposts where the Bonus series quests takes place, nothing. I go check on the Fleet just to be sure it wasn't moved there and I missed it in the patch notes, but nope, no Taris Bonus series. Were the Bonus Series removed all planets, or the level requirement increased, or is this a bug?

EDIT: I've also opened a ticket for this, just want to check here too.

PatrykJesionek's Avatar


PatrykJesionek
10.25.2015 , 12:52 AM | #2
Looks like... I was unable to start Tatooine and Nar Shaddaa. Hard to belive, that all of the sudden all bonuses got bugged. I hope that was intetional... but its EA so everything is possible

( Balmorra Bonus was playable )
Jesi Lok

Jeweledleah's Avatar


Jeweledleah
10.25.2015 , 02:01 AM | #3
I think any bonus series that are multiple levels above the normal planetary leveling - got removed. you can thank half baked lvl sync for that. of course... that may also be due to the engine, but at least in GW2 - you not only sync to specific area (even if you are in the same zone - your level automatically adjusts without loading screens) and loot that drops from mobs is for your actual level.

I mean... they COULD have just lowered levels on all the bonus series... but I'm guessing time and budget issues.

DTRO's Avatar


DTRO
10.25.2015 , 03:20 AM | #4
Guys ,

Did you try turning ''exploration missions'' on?

I turned that thingy on , and got a lot of quest back from who i presumed where ''taken away'' .

You do this by going to your map ( M button by default ) and then its in the rigth top corner of your map screen.

Please let me know if it worked for you.

Greetings ,
There is no peace no war there is only the force

Clarian's Avatar


Clarian
10.26.2015 , 12:45 PM | #5
Quote: Originally Posted by DTRO View Post
Did you try turning ''exploration missions'' on?
I tried that...it didn't fix it.

Skolia's Avatar


Skolia
11.14.2015 , 04:11 PM | #6
My new (post 4.0) character was able to *start* the Taris Bonus Series but after the "Missing Link" was completed it just stalled, unable to progress.

sirlou's Avatar


sirlou
12.13.2015 , 05:28 PM | #7
Same problem. Opened a ticket. Got an automated reply saying they do not give support on non-Story missions.
Unacceptable to tell a paying customer this. I pay for ALL the missions, not just some of them. Will I be getting a refund, I don't think so.

Fix it!!

Vitalick's Avatar


Vitalick
06.04.2016 , 10:12 AM | #8
Quote: Originally Posted by Skolia View Post
My new (post 4.0) character was able to *start* the Taris Bonus Series but after the "Missing Link" was completed it just stalled, unable to progress.
Same here