Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Can't load game after clicking play

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Can't load game after clicking play

xKrAzYkIlLeRx's Avatar

12.25.2011 , 12:18 PM | #1
I just got the game and I installed it and made an account. I tried to load the game up and when I click play it looks like it is loading and then goes to a black screen like its going to change to the game and then shuts down to the desktop. I have tried all the tips it gave me and I still can't get in. I am the administrator on this PC as I am the only one on it but I still can't seem to run it. Any help would be appreciated.

Blackstang's Avatar

12.25.2011 , 12:28 PM | #2
Post your DXdiag please.

StrikePrice's Avatar

12.25.2011 , 12:31 PM | #3

xKrAzYkIlLeRx's Avatar

12.25.2011 , 12:47 PM | #4
Processor: Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz (4 CPUs), ~2.7GHz
Memory: 2048MB RAM
Available OS Memory: 2038MB RAM
Page File: 1961MB used, 2114MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

xKrAzYkIlLeRx's Avatar

12.25.2011 , 10:52 PM | #5
Tried everything in the list from the link above and nothing has worked...