Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Am I stuck grinding?

nriemupah's Avatar


nriemupah
12.25.2011 , 11:15 AM | #1
Time of Incident: Like 3am ish PST
Character name, class, level and server: Greywolf - Bounty Hunter - Krath
Area this occurred: Corellia - Industrial Collapse quest line

I've already submitted these issues through the in game /bug report but since the automated response gives no helpful information what so ever I was hoping I could find a solution here.

Was on Corellia doing the Industrial Collapse quest line. Was at the part where you access the computer and say the cutscene where they introduce the new droid. Upon completing the cutscene the droids didn't appear and no fight started. Left the group phase, reset the mission and went back in. The mission resets back to the Meet Explosive Experts part. Upon reentering I talk to the experts again but nothing happens. They say "The droids will be here soon keep them off our backs" but the droids never show.

I left again and tried resetting local phases, nothing fixed. Tried relogging, nothing. Tried running around turning in a couple quests and coming back, still not working. The quest cannot be abandoned or reset any further.

Is there any other trouble shooting steps I can take at this point?

If not my character is officially stuck in limbo. I'm 10% from 46 and the only way I can hit 50 would be grinding PvP/Instances which holds no appeal whatsoever, coupled with the problem of there not being enough people at my level right now anyway. My class quest has been stuck since The Aurora so outside of the daily space missions I really have no way to finish the last few levels.

Azizu's Avatar


Azizu
01.07.2012 , 12:32 PM | #2
Me and my buddy whoes lvling together has got excatly the same problem, no way to fix it seems and that's just not good enough, done everything possible to fix it, nothing what so ever works!

SOME HELP WITH THIS!

Atherean's Avatar


Atherean
01.26.2012 , 02:30 PM | #3
I am also as above