Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR and Windows 10

First BioWare Post First BioWare Post

TaitWatson's Avatar


TaitWatson
07.29.2015 , 09:47 AM | #1 This is the last staff post in this thread.  
Hi everyone,

If you have upgraded your PC to Windows 10 and encounter issues with The Old Republic that you did not encounter prior to installing Windows 10, please post a description of your issue, as well as your computer's DXdiag and MSinfo reports. Please scrub any personally identifying information out of either report.

Before posting, please make sure you have also installed the latest Windows 10 driver for your graphics card. (Note: Some older graphics cards may not have a Windows 10 driver immediately available. You can check your card manufacturer's website for more information.)

Thanks!
Tait "pariahloki" Watson
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

Afet's Avatar


Afet
07.29.2015 , 11:27 AM | #2
my login client is experiencing tremendous lag since I have installed the latest version of windows 10. I am running a Geforce GTX 960. With AMD 8 core processor and 16 gigs ram. The game at this point is un playable for me framerates are so slow its unplayable

Jnaathra's Avatar


Jnaathra
07.29.2015 , 12:01 PM | #3
I want to just point out that several people had to uninstall/reinstall in other threads to fix their issues.

Telanis's Avatar


Telanis
07.29.2015 , 12:59 PM | #4
Quote: Originally Posted by Jnaathra View Post
I want to just point out that several people had to uninstall/reinstall in other threads to fix their issues.
That's overkill. SWTOR doesn't have any registry settings, so it was either a file permissions issue or they needed to delete the DiskCacheArena file and/or the client_settings and graphic settings .ini files.

Yelsewrao's Avatar


Yelsewrao
07.29.2015 , 01:21 PM | #5
I have tried several methods after updating to windows ten and every time I g to patch it says " This application has encountered an unspecified error. Please try this patch again."

Please advise.

Dalaun's Avatar


Dalaun
07.29.2015 , 02:17 PM | #6
I'm stuck in an infinite loading screen after updating. Game reinstall didn't help, might try W10 clean install later. I have the latest W10 AMD drivers.

I'd love to post dxdiag and msinfo but they're too long to post as text here.

Jboath's Avatar


Jboath
07.29.2015 , 02:29 PM | #7
Uh, this issue may be a little old but how about not having to install directx9 so the emulation from a higher version doesn't kill your fps?
Sentinel Warzone Training Dummy for Bastion Imperials.

The_Wulff's Avatar


The_Wulff
07.29.2015 , 02:37 PM | #8
The latest drivers for both AMD and NVidia (atleast through the beta of win 10) have caused serious issues with playability for SWTOR. It may help to use an older driver from win7/8/8.1 in some cases

fragnor's Avatar


fragnor
07.29.2015 , 03:38 PM | #9
Okay I got this same error message when I finished upgrading to win 10 earlier today, I did try all of the suggestions I could find and used the fixlauncher.exe and the repair option was and still is greyed out. The message comes up with the launcher and gives me an option to ignor abort and retry, when I ignore it it looks like the game loads normally but I get an empty server list. The error message reads:

Microsoft Visual C++ Runtime Library

Assertion Failed!

Program:..
File: ..\..\..\src/c/platforminfo\Platforminfo_Win32.cpp
line 434

Expression: platformUtilsInitialized

For information on how your program can cause an assertions failure, see Visual C++ documentataion on asserts

(Press Retry to debug the application - JIT must be enabled)

(ther is ofcoarse Abort, Retry, and Ignore buttons on the bottom of the window.


I did attempt to uninstall and reinstall to no avail the same thing is happening, and I only did so after trying everything else that was suggested.

I can get any extra info (ie logs and so forth) if you can tell me where to look for them

I have my saved dxdiag and msinfo files but they are both way to big to post so if you can let me know how I can shorten them or give me some area to post of those reports I can do that.

Unext's Avatar


Unext
07.29.2015 , 04:13 PM | #10
My Client doesn't do ANYTHING. I click the icon the hour glass spins then goes away and the launcher never appears.