Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Sniper Penetrating Blasts Bug


DarkDoz's Avatar


DarkDoz
04.07.2015 , 02:21 PM | #1
Quote:
In PVP when using a Marksmanship build on my Sniper Penetrating Blasts only fires 4 shots then reloads and doesn't apply reestablish range knock back when finished. After using Sniper Volley Penetrating Blasts fires all 5 shots and applies knock back effect like its supposed to. Basically, the devs need to fix the Penetrating Blasts ability to fire all 5 shots again like its supposed to and apply the Reestablish Range knock back when its picked in the specialization box.
Info post here http://www.swtor.com/community/showthread.php?t=803107

I PVP and this is a BUG

Need to give Agents Sniper some love
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

HuNtOziO's Avatar


HuNtOziO
04.07.2015 , 05:22 PM | #2
Main reason for this is that god awful new pen blasts animation. The animation bugs out often, doesnt shoot all shots properly and doesnt even make the firing sound effect everytime. The original one when 3.0 came out was *far* superior and never had this bug either.

I pvp on my sniper also, please restore the original and superior animation for penetrating blasts and be done with it. easy fix.

(posted this on both threads)
- Spoonmeister [Sniper] - Spoonyspoon [Sorc]
- Huntopia [Sin] - Elodie [PT]
- Elodiť [Sentinel] - Elodie-deux [Operative]
- Nova (Co-Guildmaster) - Red Eclipse server, Europe

DarkDoz's Avatar


DarkDoz
04.08.2015 , 03:05 PM | #3
Thank you HuNtOziO
We can only hope they fix this soon.
Bioware posted a Bug with Jedi low Slash that seem to be never ending stun.

lets hope they have a Hot fix within days and not weeks.
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

orangebubbly's Avatar


orangebubbly
04.15.2015 , 10:10 PM | #4
Hello! I have encountered a funny animation bug on Penetrating Blast's animation on the lower jaw, it seems to vanish :

http://gyazo.com/e8d4b488a5a505a655762faed36ae318

As far as I know it happens on Female Body Type1... or just to me.
I have not been able to test it on other snipers seeing as this is my only one.

DarkDoz's Avatar


DarkDoz
04.16.2015 , 11:07 AM | #5
Jedi low Slash was fixed / Thank you
Bioware we are still waiting on Sniper Penetrating Blasts bug fix
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

Darth_Wicked's Avatar


Darth_Wicked
04.17.2015 , 05:33 AM | #6
That. Was. Creepy.

DarkDoz's Avatar


DarkDoz
04.23.2015 , 10:14 PM | #7
Bioware need to fix this issue
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

DarkDoz's Avatar


DarkDoz
04.29.2015 , 04:45 AM | #8
I was hoping when 3.2 patch came out this would have fixed the Sniper Penetrating blast Bug but NO
Now I see this graphic bug even more now PVE and PVP.
Animation is all messed up and was explained here and l in many post on this forum.
As a paying customer since Beta you need to address this BUG ASAP
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

DarkDoz's Avatar


DarkDoz
04.29.2015 , 08:50 AM | #9
Bioware please acknowledge you know about this BUG and when you will FIX.

Note another post on same BUG
http://www.swtor.com/community/showthread.php?t=808016
The Shadowlands server
Dozinator L65 Scoundrel DPS Dozi L65 Scoundrel Healer
The Shadowlands server
Lost'Her L70 Sniper DPS Lost'Him L70 Operative Healer

Ubikface's Avatar


Ubikface
04.29.2015 , 10:42 AM | #10
Quote: Originally Posted by DarkDoz View Post
I was hoping when 3.2 patch came out this would have fixed the Sniper Penetrating blast Bug but NO
Now I see this graphic bug even more now PVE and PVP.
Animation is all messed up and was explained here and l in many post on this forum.
As a paying customer since Beta you need to address this BUG ASAP
Yeah, it used to be the occasional bug out pre 3.2. Now I see it pretty much every cast. It's really annoying.