Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Terribly slow download speed, suggestions?

STAR WARS: The Old Republic > English > New Player Help
Terribly slow download speed, suggestions?

Yvvy's Avatar


Yvvy
04.04.2012 , 02:03 PM | #31
I use to download like 300kbs, then i changed time zone like 10 hours difference. I did paused then play, and suddenly i got 3.90Mbps. I will try diff timezones to see if any big differences. Edit: I did and seems download speed depends on time zone.

Tolian's Avatar


Tolian
04.08.2012 , 12:43 PM | #32
hi guys, I apologize for not replying in awhile. quick way to find out where your game is installed is right click the launchers shortcut on desktop/quicklaunch/startmenu view the properties of it to find out where it's installed (target field)

swtor needs 2052, 2053, 8995, 12000-12999, and 20000-30000. opening these in your respective routers setup page for port forwarding -should- help clear up some of the speed issues. make sure the launcher.exe is allowed in your firewall software (whatever that may be) and make sure the firewall software is set to allow modifications/exceptions. Because even if you have it added, and don't allow exceptions is on. it basically flips it back to default mode (in some cases) meaning it's not allowing anything but standard stuff. (and judging by the wacky port-ranges swtor is anything but standard.

oh, also. opening a command prompt (start run cmd) netstat -n -o will show process identifiers as to what program is communicating with what port on your computer. leftside being local, (you) right side being where it's going. if a port range exists outside of what a company says their game uses, just modify it in your router settings. Process identifiers can be shown in the windows task manager and are turned off by default


For windows xp ctrl alt delete, view menu, select columns. check pid (windows 7 same thing i believe)

hope this helps you guys out!

Rette's Avatar


Rette
04.12.2012 , 04:54 AM | #33
Thanks so much for the post about editing the launcher.settings file. Just did that and my download went from 35kbs to 4.28 Mbs. Much appreciated bud.

Termingus's Avatar


Termingus
04.12.2012 , 04:55 AM | #34
i just did the pause start thing and went from 64 too 700+KB/s

Fei-Ke's Avatar


Fei-Ke
04.12.2012 , 07:04 AM | #35
Thanks for the pause tip, went from 700kB to about 9Mb
Republic - PvE - EU
► ► R i s i n g P h o e n i x ◄ ◄
http://riph.enjin.com

Evilbeliefs's Avatar


Evilbeliefs
04.12.2012 , 09:13 AM | #36
Quote: Originally Posted by antonuppsala View Post
Thanks for all the replies, ive tried pausing and re-starting, it helps speed up connection when its slow but if its mediocre then it might just aswell drop down to slow. Bit of a gamble there hehe.
I just tried this and it went from 129 KB/s to 1075 KB/s, cheers for the idea. It has slowed down a little bit but its average is about 722KB/s.....I can live with that.......for now

APhantasm's Avatar


APhantasm
04.12.2012 , 10:12 AM | #37
Neither launcher.settings or adding the ports to my router worked. Its odd according to Speed Test, I get 1.5 Mb/s download. Yet the launcher (and bittorrent - which isn't running right now) gets only 175 Kb/s download max. And its always been like that, I can't figure out why speed test says I should be getting faster speeds but no matter what I do I can't get those speeds.

GymQuirk's Avatar


GymQuirk
04.12.2012 , 10:21 AM | #38
Quote: Originally Posted by APhantasm View Post
Neither launcher.settings or adding the ports to my router worked. Its odd according to Speed Test, I get 1.5 Mb/s download. Yet the launcher (and bittorrent - which isn't running right now) gets only 175 Kb/s download max. And its always been like that, I can't figure out why speed test says I should be getting faster speeds but no matter what I do I can't get those speeds.
Keep your bits and bytes straight.

1.5 Megabits/sec does work out to around 170 kilobytes/sec after allowing for error correction and other transmission overhead.

APhantasm's Avatar


APhantasm
04.12.2012 , 10:50 AM | #39
Quote: Originally Posted by GymQuirk View Post
Keep your bits and bytes straight.

1.5 Megabits/sec does work out to around 170 kilobytes/sec after allowing for error correction and other transmission overhead.
Thanks for info. Though thats a shame, I had hoped it was bytes instead of bits. That would mean I just had to find out what was causing the slow down and fix it. Now I know the only way to fix the slow down is to pay my ISP even more money.....

Which also means I won't be playing for the majority of the day, I'm downloading the 4.81 gb portion of 1.2 as I write this. Cause at 170 Kb/s It will take till about 5 or 6 pm CDT (it's almost 12pm now), at which time I will be gone for two hours. I might be able to get some play time after I get back before going to bed though.

Venefykas's Avatar


Venefykas
06.26.2012 , 07:55 PM | #40
Quote: Originally Posted by Tolian View Post
1. game directory
2. filename launcher.settings
3. open with notepad
4. scroll to bottom, edit "P2PEnabled": "true" <-- may be set to false
5. save with notepad

fixed mine,now back to usual 2.65mb/s speed

cos i'll be damned if i'm kept from playing what i paid for cos of minor screw ups, hope this works and see all you new guys in the game, enjoy!



Furthermore www.speedguide.net download tcp optimizer, open it.

open browser www.speedtest.net begin test, whatever download says in mbps go into tcp optimizer program set top scrolly bar to that, check optimal box. apply, reboot.
I scrolled to the bottom, and I couldn't find anything about P2P. This is the last line.


[Tuesday Jun 26 16:38:40 2012] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Tuesday Jun 26 16:38:40 2012] | STAR WARS: The Old Republic installer finished
[Tuesday Jun 26 16:38:40 2012] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


Even though it says finished, I am still downloading. Can anyone give me advice as to what to do here?