Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

why cant i get this game to launch

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
why cant i get this game to launch
 

RajAtton's Avatar


RajAtton
12.24.2011 , 10:48 AM | #1
So i have tried everything i can do and now im into day four and simply cannot get this thing to launch. it does the whole black screen for a couple of seconds after i hit play on the launcher...........roar im getting mad. please someone help me
Raj Atton
Sith Battlelord

Goano's Avatar


Goano
12.24.2011 , 10:55 AM | #2
have you tried re-downloading the launcher from the homepage? Basically, follow the links to "Download" the game. Except, since you have all the files, it just cruises through and checks everything. In my case, the LAUNCHER wasn't getting updated, and causing a crash.

I downloaded the 37.9 Meg launch, opened it up, it updated itself, and problem solved.

brianthedawgfan's Avatar


brianthedawgfan
12.24.2011 , 10:59 AM | #3
Same here! This game is a piece of crap! Been trying to launch SINCE TUESDAY!

xelitex's Avatar


xelitex
12.24.2011 , 11:01 AM | #4
Change the full screen settings from true to false in the system folder, would tell you how to get there but I dont remember the whole process hopefully someone else here does

brianthedawgfan's Avatar


brianthedawgfan
12.24.2011 , 11:25 AM | #5
I've tried that along with everything else...nothing works!

clanbishop's Avatar


clanbishop
05.07.2012 , 11:17 PM | #6
Dealing with same problem. Got a new computer all specs were better than last and am not able to launch. Did everything tec ticket said to do. This is frustrating.