Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error in purchasing Star Wars™: The Old Republic™ Digital Upgrade Pack

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Error in purchasing Star Wars™: The Old Republic™ Digital Upgrade Pack

SimonLam's Avatar

12.24.2011 , 06:30 AM | #1
Hi support,

I have registered my retail key for Standard Edition and completed all 5 ticks for my account (ie security questions, retail key, monthly subscription, mobile authenticator, etc). When i tried to purchase upgrade of my account from standard to Star Wars™: The Old Republic™ Digital Upgrade Pack, it keep showing this error code:

"It seems that this purchase request has already been submitted. If you want to make another purchase, start over. "

I have tried using 3 different credit cards: VISA, AMEX and the outcome still the same. I tried to raise an ingame ticket but i received a standard email reply template not addressing my problems. I only managed to receive the same standard email reply when i tried to clarify further.

Can anyone help or advise me what to do to "get my purchase completed"?

Note: There is nothing wrong with my credit card details as i have no issue registering my subscription on swtor and no issue with online purchases such as, etc.

Thank you.


PS: The email from SWTOR Customer Service as follows:


I am Protocol Droid M0-T0, Human Cyborg Relations.

Thank you for contacting us regarding your subscription issue.

When registering a credit/debit card on your Star Wars: The Old Republic account, a small charge is made in order to verify that the card is valid. The charge is applied to your card as a part of our standard card authorization process. This charge is temporary, and should be refunded to your account within 5 working days.

If you encounter difficulties registering a card, including multiple small charges being placed on your account and receiving an error message advising you to use another card, please be aware that this means that your card has failed a step of the authorization process. In order to resolve this issue, please contact your bank or credit card provider and find out why your card failed the authorization process.

Thank you for your patience and understanding, and we would like to apologize for any inconvenience this process may have caused. If you have any further questions, or require assistance any other issue, please do not hesitate to contact us again.

Galactic Support is our Specialty...


Protocol Droid M0-T0
Star Wars: The Old Republic Customer Service.