Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Failed to load the required icudt library

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Failed to load the required icudt library
 

Zalewind's Avatar


Zalewind
12.23.2011 , 10:27 PM | #1
Failed to load the required icudt library.

What does this mean and how can I fix it?

trentguerra's Avatar


trentguerra
12.24.2011 , 10:21 AM | #2
i have had the same problem, cant figure it out?

Zalewind's Avatar


Zalewind
12.24.2011 , 11:22 AM | #3
I received a reply saying to go to www.swtor/download and re-download the launcher. It looks like it will re-install the game, but it doesn't. This worked for me. Thanks, and God bless