Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Cannot get to Ord Mantell Station

STAR WARS: The Old Republic > English > New Player Help
Cannot get to Ord Mantell Station

tueborvita's Avatar

06.03.2014 , 07:50 AM | #1
So I acted completely on autopilot for my smuggler and went straight to the republic fleet instead of going to the space station. I went back to Ord Mantell and tried to go to the station from there, but it keeps saying that I am not eligible. I've tried resetting the quest: no go. I've tried moving on to Coruscant: won't let me start my class missions. Any advice?

Bstr's Avatar

06.03.2014 , 08:09 AM | #2
You cannot get to the Ord Mantell Station until after Coruscant.

If you are on the mission, "Chasing Skavak," you are supposed to go to the Ord Mantell Shuttleport, then use the shuttle there to go to the Fleet.
Bobuster: Sab. Guns. Robcase: Seer Sage Bosha: Def. Guard. ShepardCmd: S.S. Vang.
Bosat'ta: BG Merc. Bophia: Fury Maur. Borbend: Med. Op. Bo'ya: Dark. Sin
<Reformation> Ebon Hawk Server

tueborvita's Avatar

06.03.2014 , 08:24 AM | #3
The problem is that I cannot get to the shuttleport. I got to Fleet. I got to Coruscant. But I cannot go any further in my class mission because it wants me to get to the shuttleport. How do I manage to get to there when it won't let me access it from Ord Mantell or from the Fleet shuttle to Ord Mantell?

tueborvita's Avatar

06.03.2014 , 08:50 AM | #4
Figured it out.

There was another fight with no pointer towards it. The instructions said to take a shuttle to the fleet and you have to go to the other side of the space port to get to the ambush. Once you do that you STILL do not go to the spaceport, instead you go directly to the Fleet and get the reward there. That quest needs cleanup.

Luneward's Avatar

06.03.2014 , 10:45 AM | #5
No, it really doesn't. The building you were in to get to the fleet is the spaceport. The orbital station is something different, and only accessible once you have a ship. There's nothing that can be 'cleaned up' if you don't realize that a building with shuttles/ships in it is the spaceport building.
Steelwind / Kaillen * The Ebon Hawk

ConcreteRyder's Avatar

06.03.2014 , 02:02 PM | #6
I believe he is talking about the Smuggler mission that tells you to go to the spaceport doesn't tell you to go to the right instead of left when you enter the building. Since the shuttle that takes you to the fleet is to the left, it's an honest mistake. I made the same mistake when I first played my smuggler.