Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

permanent crashes, followed by "Select Server-Screen" and Error Code: 4001

STAR WARS: The Old Republic > English > Customer Service
permanent crashes, followed by "Select Server-Screen" and Error Code: 4001

TarisKnight's Avatar


TarisKnight
05.19.2014 , 02:51 AM | #1
Hi everyone,

the log in into the game works perfectly, but after each 20 to 25 min I get thrown out of the game, land at the "Select Server"-Page and the Error Window with the text:

"Unable to retrieve server list. Please follow the Help Center link below for more information. The game client will now close" Error Code: 4001 (below)

When I then click on "ok", I am back to desktop. Restarting and then relogging works without problems.

What might be the cause of this?

Cheers,

Tarisknight

OwenBrooks's Avatar


OwenBrooks
05.19.2014 , 03:08 AM | #2
This is normal when the game loses connection, cause can be local or it can be a net issue, is there any lag associated with this at all ?

things to check on your end is obviously that both launcher.exe and swtor.exe are in all the exception lists for the AV/Firewall, also if a firewall exists on the modem.

If playing wireless try playing wired and see if it persists

Edit - try a different DNS server - http://answers.microsoft.com/en-us/w...c-eefca5d278d0

Also you can avoid the client close by memory by clicking more info on the error message box

TarisKnight's Avatar


TarisKnight
05.19.2014 , 02:59 PM | #3
Thanks for your reply.

But this started happening suddenly after more than 2 years of playing. There is also no lag whatsoever. The connection is a 200 Mbit fibre connection which is running always smoothly. Usually, before I got the crash, I have a around 20 ms latency. So I am quite at a loss what to do in that case.

TarisKnight's Avatar


TarisKnight
05.20.2014 , 02:19 AM | #4
Why is no one from costumer service responding?

OwenBrooks's Avatar


OwenBrooks
05.20.2014 , 03:01 AM | #5
Run a repair done by one of two ways below and delete the games cache file just to be sure

If you have the letters ST on the lower left of the launcher, close the launcher , right mouse click on game shortcut, select open file location , delete the bitraider folder, then in a swtor folder here delete the file called diskcachearena (don't delete the swtor folder , start the launcher.

If no letters ST on the lower left , after login , goto the lower left cog and select repair ,close launcher and still delete the diskcachearena file mentioned above then start the launcher.

Take the system to a clean boot as per http://support.microsoft.com/kb/929135 and see if it persists

TarisKnight's Avatar


TarisKnight
05.21.2014 , 02:23 AM | #6
Update: since the latest patch/maintenance the problem appears to have disappeared thankfully.