Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Galactic Datacron Master Achievement (bugged)

STAR WARS: The Old Republic > English > Customer Service
Galactic Datacron Master Achievement (bugged)

BobSonsler's Avatar


BobSonsler
05.18.2014 , 06:41 PM | #1
I've seen utterings about similar legacy issues before but can't find a thread related directly to this problem and had to put it up here where I am hopeful it can be solved.
I've just found all datacrons from every location across both the Republic and Imperial factions, was excited for the achievement - but it wasn't awarded.
My Imperial character found his datacrons before the achievement system was live so I'm finding out now, he doesn't get credit for them and never will because he's already found them and can't get them again. I checked my codex and every datacron is listed there that I am showing as missing from my Achievement log. Is there some way to check against codex entries for legacy achievements? This is a heartbreaking thing as I only have the one imperial toon - literally all of my other characters are Republic and I'm fairly rooted there with an active guild, etc.
Please tell me there is a workaround for this. I've submitted a ticket but am trying to cover ever possible base....

SayEndo's Avatar


SayEndo
05.19.2014 , 07:25 AM | #2
I know your Imp toon has already gotten the Imp only ones, but have you tried going back to them anyway? You can still click them, but it'll give you the message that it's already been accessed. It -may- get the achievement to acknowledge that you've gotten it because you've done the required action. I can't say for sure that it'll work, but it may be worth a shot.