Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher Problems

Alasteir's Avatar

03.19.2014 , 12:03 PM | #1
So this morning the launcher was working perfectly. Went to use Swtor Unleashed, tried it, still worked, deleted it, and ran Windows Update, and now the Swtor Launcher won't even start up. The Icon on the task bar shows up, and the outline of the launcher shows up but then closes.

Here are the things I've tried to fix the issue.

1. Ran using the recommended compatibility mode.
2. Ran a scan using Mal-ware Bytes, and found nothing.
3. Tried to redownload the game, but the fresh install has the same problem, and won't run the launcher.
4. Restarted my computer
5. Turned off the firewall
6. Checked my email for any password I might have in which I have to put in before running the game.
7. Checked to see if other programs have similar issues, but only Razor Game booster had a similar issue in which it wouldn't even start up, but I deleted it entirely. So the issue seems to only affect Swtor.

Also the game always runs on Administrator mode.

And none of these have done nothing to fix the issue. Can anyone enlighten me as to what exactly is happening here?

OwenBrooks's Avatar

03.19.2014 , 02:24 PM | #2
Before you uninstalled unleashed did you select "remove and quit" , before deleting it ?