Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher Delay

Theomis's Avatar


Theomis
03.16.2014 , 02:36 AM | #1
When ever i click on the launcher on may desktop it takes about a minute to 1 1/2 minutes to launch and sometimes takes more than 2 minutes then when it launch it there is a problem and i have to check the forums.

I noticed that only way to close it at this point is using the task manager and try again.

Any suggestion would be appreciated.

Thank you

Edit: i have run it as administrator and no result and of course it has an exception on the firewall

OwenBrooks's Avatar


OwenBrooks
03.16.2014 , 02:48 AM | #2
Goto a clean boot - http://support.microsoft.com/kb/929135 if it behaves then enable one thing at a time until you find the culprit

Which AntiVirus do you use and is launcher.exe and swtor.exe in all exception lists

Theomis's Avatar


Theomis
03.16.2014 , 05:49 AM | #3
I use Eset as antivirus and firewall, is there any ports i have to config just in case?

OwenBrooks's Avatar


OwenBrooks
03.16.2014 , 06:10 AM | #4
With Eset ensure "protocol filtering" is disabled and/or launcher.exe and swtor.exe is in that specific exception list, that may be just what the issue is with the delay

Theomis's Avatar


Theomis
03.16.2014 , 06:37 AM | #5
looks like the problem was with Eset protocol filtering and now it's fixed, tyvm

OwenBrooks's Avatar


OwenBrooks
03.16.2014 , 06:39 AM | #6
Welcome mate, glad to hear its sorted