Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

[IMPORTANT] Character Loading Issues

STAR WARS: The Old Republic > English > Customer Service
[IMPORTANT] Character Loading Issues
First BioWare Post First BioWare Post

Cybrias's Avatar


Cybrias
04.22.2014 , 06:06 AM | #201
1. Server: The Red Eclipse

2. Characters: Cant get to selection so not character based

3. Process: Login to SWTOR but gets stuck on open splash/load screen

4. Work around: Tried repair, router reset no luck

5. Occurs after pressing play button and splash screen comes up

Guntarius's Avatar


Guntarius
04.22.2014 , 06:11 AM | #202
Been sitting around watching the GS load screen off and on for almost an hour (broken up between the times I tried restarting, but over 10 minutes consecutively more than once). Nada. Spinning widget, Galactic Starfighter loading screen I see way too much of anyways, and nothing else. This site says the server is up and running as well. Can we get any kind of update to what's wrong or should we give up entirely on that glimmer of hope?

Primary Server: Begeren Colony

SASColfer's Avatar


SASColfer
04.22.2014 , 06:12 AM | #203
Pretty much same as others.

Server: Tomb of Freedon Nadd

Problem: Stuck on open spash screen after logging into account. (The Starfighter screen)

Waited: 15-30 minutes, no progress.

lfulax's Avatar


lfulax
04.22.2014 , 06:13 AM | #204
Hi,

My characters are on the English server "The Progenitor" and I cannot seem to log on. I get the error 3003 code.

I have tried for the last hour but nothing seems to work.

Do you know whether this is a similar thing to other people or is it just me?

Blackoutstalker's Avatar


Blackoutstalker
04.22.2014 , 06:16 AM | #205
1. Server: Tomb of freedon nadd

Cant even get to character selection just get stuck on the Galactic Starfighter loading screen and wont go any farther been on it for 15mins and nothing.

Thronesz's Avatar


Thronesz
04.22.2014 , 06:16 AM | #206
Can log in, but after pressing play I get stuck in the splash screen.

Server: The Progenitor.

jabberwoky's Avatar


jabberwoky
04.22.2014 , 06:17 AM | #207
Can't get past loading screen to character select. First time this has happened to me.

Server: The Bastion

Problem: Stuck at loading screen pre-character select. Tried deleting DiskCacheArena and running a repair with no luck. Let the loading screen churn for over 30 mins and still nothing.

Guntarius's Avatar


Guntarius
04.22.2014 , 06:18 AM | #208
Finally made it past the GS loading screen to the server select screen. Clicked on Begeren Colony to log in. Ships are moving in the background and it says "Logging into selected server". So far, nothing.

Tir_Ramas's Avatar


Tir_Ramas
04.22.2014 , 06:18 AM | #209
At least it is not just me, Tomb of Freedom Nadd and cant get to char loading screen.
Do or Do not, there is no try.

littlejstivers's Avatar


littlejstivers
04.22.2014 , 06:21 AM | #210
Harbinger sever
Loads splash screen shows its running in task manager but never pulls up character selection page stuck on slash sreen.