Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Login service down?

Ranadicus's Avatar


Ranadicus
11.28.2013 , 11:03 AM | #1
As the title says I cannot login. I am wondering if there is a outage or am I going to have to waste my double XP Thanksgiving re-downloading and reinstalling the game?

Allow me to preface by saying I was last logged in about 10 hours ago without problem. At first I was getting the "Network Error. Check your internet connection". My Internet connection was and is working fine. I'm posting this on the same computer.

I tried to run the repair which didn't even seem to register. I ran the FixLauncher.exe without success. I then downloaded and ran the setup again. After this I seem to have an older version of the launcher that isn't updating itself (it asks for my email address or trial account name) and when I try to login it just tells me the login service is down.

I tried deleting the settings folder in AppData\Local but when that failed I restored it.

I have gone ahead and disabled my firewall and setup exceptions in Bit Defender but I have been playing without these things for quite some time now. I excepted the entire SWTOR folder just for sake of being thorough.

Thanks

EDIT: Wow, my old forum sig is still here, lol
╬╬╬╬╬╬⋐⋑(ē)[███████████████████████████████)CE 7/21 7:44 AM 10/4 beta drinking game survivor

Dythragor's Avatar


Dythragor
11.28.2013 , 11:06 AM | #2
there are 2 other posts about loging issues. I am having the same issue and probably many more. I am pretty sure something happened. i hope they extend double xp weekend...

kmufc's Avatar


kmufc
11.28.2013 , 01:05 PM | #3
I cant login either, the game takes forever to load up and then no servers appear.

Im re-downloading the game to see if that helps.

Im on The Red Eclipse server

KingAlen's Avatar


KingAlen
11.29.2013 , 02:12 PM | #4
Same here. I took a break for 10 min from the game and come back to this

Adasas's Avatar


Adasas
11.29.2013 , 02:21 PM | #5
same here, "Login service is currently unavailable" i try fix launcher but nothing happen, server - Tomb of Freedon Nadd.

Rotaruc's Avatar


Rotaruc
11.30.2013 , 04:35 PM | #6
i just took a break for about 15 min and tried to log back in when it told me that the login service is currently unavailable. Im guessing that were having these problems because so many people are playing right now bcuz of dxp.
"NwŻl tash. Dzwol sh‚sotkun. Sh‚sotjontŻ ch‚tsatul nu tyŻk. TyŻkjontŻ ch‚tsatul nu midwan. MidwanjontŻ ch‚tsatul nu asha. AshajontŻ kotswinot itsu nuyak. Wonoksh Qy‚sik nun."
-Sorzus Syn, Writer of The Sith Code