Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

launcher flashes for a milisecond, then quits

STAR WARS: The Old Republic > English > Customer Service
launcher flashes for a milisecond, then quits
First BioWare Post First BioWare Post

carboncollector's Avatar


carboncollector
10.31.2013 , 03:30 PM | #31
Just tried Windows 7 fresh install, no good either..........

Embraer's Avatar


Embraer
10.31.2013 , 11:19 PM | #32
Add me to the list... Just got a new 15" MBP, running Win7. Followed all the suggestions from this thread and others. No luck whatsoever. A flash of the Launcher then gone. I'm glad I still have my old MBP so I can still play, but I was really looking forward to playing on the retina display

OwenBrooks's Avatar


OwenBrooks
10.31.2013 , 11:34 PM | #33
Quote: Originally Posted by carboncollector View Post
Just tried Windows 7 fresh install, no good either..........
Just to check on something, but I suspect it may be a low level driver issue

The Win 7 install

Does it have
.net 4 - http://www.microsoft.com/en-au/downl....aspx?id=24872 plus any windows updates ( or 4.5 )
VS C++ 2010 - http://www.microsoft.com/en-au/downl....aspx?id=14632 plus any windows updates sp1 etc
directx 9 - not needed but hey we are here - http://www.microsoft.com/en-au/downl...s.aspx?id=8109

Edit - When you start the launcher , start it as administrator and compat mode for XP Sp3, if this works ensure swtor.exe is set as XP Sp3 as well.

archivistrudi's Avatar


archivistrudi
11.01.2013 , 10:58 AM | #34
I wrote feedback on apple.com/feedback about bootcamp for that specific machine needing drivers update. Feedback is under OS X, subcategory hardware and software compatibility and boot camp. I know it's a long shot but hopefully gets voice heard.

archivistrudi's Avatar


archivistrudi
11.01.2013 , 09:26 PM | #35
Just checked for everything that's needed installed, and tried as Admin + windows xp sp3 compatibility mode - still same crash

halugenu's Avatar


halugenu
11.03.2013 , 06:28 PM | #36
Hello, 1st time poster here. I wish I had came here before dropping $2800 on a computer that wont run the only game I play. Ive also done everything as far as troubleshooting and drivers are concerned. I am running in Windows 7. If that helps.

ShaderGuy's Avatar


ShaderGuy
11.04.2013 , 10:43 AM | #37
I have the same issue with my brand new MacBook Pro 15". The launcher won't run. I've tried all of the things posted in this thread and others. I'm hopeful that a solution can be found soon.

archivistrudi's Avatar


archivistrudi
11.04.2013 , 11:38 AM | #38
For those with Windows 7, it helps if tech support is called so they get the logs and are aware of the issue. This is most likely old apple driver issue, but maybe swtor can update something in launcher to make it run too - after all other games run ok. I'm on windows 8, which tech support doesn't support - still looking for my old windows 7 key.

halugenu's Avatar


halugenu
11.04.2013 , 04:28 PM | #39
I did call Tech Support and send my diagxxxxxxxxxxxx.tgz file as directed. Patiently waiting. All this could be avoided if they would make a mac client.

kanjiten's Avatar


kanjiten
11.04.2013 , 06:07 PM | #40
Add me to this list of having the exact same issue with the launcher. Completely unable to play the game the last week+. Brand new MacBook Pro, BootCamp 5. No issues whatsoever on my older (2010) MBP running BootCamp 4, which I'd played the game on since beta.