Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Stuck at character select screen

 
First BioWare Post First BioWare Post

Rift_Stalker's Avatar


Rift_Stalker
10.15.2013 , 10:43 PM | #1
I am having a problem logging in to some of my characters.

I was playing like normal and the game crashed. After loading the game back up again and picking my server, I couldnt get my main character to log in. I would push the "Play" button and the sound effect would trigger like normal, but thats it. No loading. There are several characters that I cant get to log on now and they are all logged off in different areas (Fleet, personal ship, Nar Shaada, etc.) And some characters log in fine. I tried to switch servers and log in an alt and they all logged in just fine.

I am looking for a solution that does not involve deleting game files and reloading everything from scratch. If that is the only option then I will start patching a different game at the same time, and which ever finishes first gets my sub money... we all know how craptastic the swtor patcher is and slow.

Thanks in advance for any help.

Beruthien's Avatar


Beruthien
10.15.2013 , 10:59 PM | #2 This is the last staff post in this thread.  
Greetings Rift_Stalker,

Please do a Clean Boot and then please run repair function on the launcher (if you are using the non-streaming launcher), if you use the streaming launcher (ST in the bottom left hand corner), please make sure that the patching has finished and then follow the steps below:
  1. Close both Launcher and SWTOR.
  2. Delete the “BitRaider” directory from your game install directory
    1. For 32 bit Operating Systems - C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\BitRaider
    2. For 64 bit Operating Systems - C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\BitRaider
  3. Run the Launcher
Please come back to us the issue remains.

Thank you!
Beruthien| BioWare Customer Service – Forum Support

LokiLaufeyson's Avatar


LokiLaufeyson
10.26.2013 , 05:49 AM | #3
Same problem here (Begeren Colony), the screen stuck at 20% after choosing the character. After several minutes the game back to servers screen. I have try 10 times until connect. I have done everything, updated my video drivers, use the repar, reinstalled the game and nothing worked. Does anyone have any suggestions, ideas or voodoo that works?? I have several characters level 55 and I can not play with any!

KTap's Avatar


KTap
01.08.2014 , 01:22 PM | #4
Quote: Originally Posted by Beruthien View Post
Greetings Rift_Stalker,

Please do a Clean Boot and then please run repair function on the launcher (if you are using the non-streaming launcher), if you use the streaming launcher (ST in the bottom left hand corner), please make sure that the patching has finished and then follow the steps below:
  1. Close both Launcher and SWTOR.
  2. Delete the “BitRaider” directory from your game install directory
    1. For 32 bit Operating Systems - C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\BitRaider
    2. For 64 bit Operating Systems - C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\BitRaider
  3. Run the Launcher
Please come back to us the issue remains.

Thank you!
I'm having the exact same problem as the OP. The only solution I've found is to exit the entire game and start it back up again (which is not ideal).

I tried deleting BitRaider after repairing, and the problem is still persisting. I know at least one other person who is also having this exact same problem. Any other ideas for fixing would be appreciated, thank you