Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Receiving “Host Update Failed” Message During the Launcher Update? [Edited]

STAR WARS: The Old Republic > English > Customer Service
Receiving “Host Update Failed” Message During the Launcher Update? [Edited]
First BioWare Post First BioWare Post

Bronholz's Avatar


Bronholz
10.03.2013 , 01:16 PM | #21 Click here to go to the next staff post in this thread. Next  
Quote: Originally Posted by Snarkasms View Post
It doesn't seem as if the patch is corrupting, it seems that it thinks it needs to verify the preexisting game files every time. I have no reported issues with my SSD or HDDs, and the RAM has reported no errors, but next time I take a downtime, I'll triple check. Thanks.
Hi Snarkasms,

If you're consistently having issues patching, it maybe worth switching launcher settings.

Many players who were having issues with the SSN (Non Streaming) setting, found that changing to the BitRaider (streaming) setting stopped these issues from occurring.

It's easy to change to the BitRaider setting, just follow the steps here.

Due to the description from your post, we feel that you may have a better patching experience with the BitRaider setting, but please be aware that if you would wish to switch back to the SSN setting, it would require a full re-download of the game.

Thanks.
Bronholz | BioWare Customer Service – Forum Support

Neoforcer's Avatar


Neoforcer
10.03.2013 , 01:25 PM | #22
Host Update Failed

Just had this issue your LauncherRepairUtility1_75_5.exe would not fix it. I kept getting the error over and over again. So I ran the launcher by right clicking the launcher.exe and under the context menu selected run as Administrator. The launcher updated all files fully with out the LauncherRepairUtility1_75_5.exe. So it is possible that one of the files in my swtor folder has it's privileges messed up on my pc and stopping the launcher from replacing the files. Your new repair utility does not work with the Host Update Failed error this time. As it does not ask you to replace the files which the old one did. When you say yes to all it will over right the file with possible bad privileges. Allowing you the then update normally.

My windows account has full admin privileges and Windows UAC is off so every thing is run as admin. Hope this helps point every one in the right direction going to try setting the properties of the launcher to all ways run as admin see if i see it again the next update.

My laptop also has this same issue at home since i am on my work pc i will check if running the launcher as Administrator works without the LauncherRepairUtility1_75_5.exe to see if the host file error goes away.

P.S PC repair tech so working with windows and doing what you suggest and more I am more then comfortable with. After i get home i will try the above and post the results with my laptop

CymLN's Avatar


CymLN
10.03.2013 , 05:01 PM | #23
One of the issues I have is that if the Launcher update utility fails, I am unable to "end process" for launcher.exe and sometimes for launcherupdate.exe when going to the process window of task manager selecting the program and selecting end process. Because the process persists, further attempts at fixing result in a "cannot update host" notice. I did run the diagnosis tool during one of my sessions and was going to attach, but don't see that option.

Turrell's Avatar


Turrell
10.05.2013 , 06:13 PM | #24
Yes keen to assist, launcher stalls on 'installing main assets 138'. Doesn't progress past 0%. Have tried using the launcher fix btw.

GeneralOzeransky's Avatar


GeneralOzeransky
10.05.2013 , 06:19 PM | #25
Is someone going to address the Error 9000's? You're going to lose subscribers.

Wernicke's Avatar


Wernicke
10.08.2013 , 06:16 AM | #26
Update server is not available. I'm fine with the Internet, everything works except the update server. When will it end?

Beesodd's Avatar


Beesodd
10.08.2013 , 06:21 AM | #27 Click here to go to the next staff post in this thread. Next  
Hi Wernicke,

Is that the exact error message you're getting? Can you post up your launcher logs within spoiler tags?

You can find your launcher logs at one of these default locations:

- For 32 bit Operating Systems - C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\logs
or
- For 64 bit Operating Systems - C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\logs

Launcher logs look like this: “launcher_112610.txt”

Thank you.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Wernicke's Avatar


Wernicke
10.08.2013 , 06:47 AM | #28
I do not have a file named "launcher_112610.txt", the last file in the log called "launcher_20131008".
Publish its contents, I can not, the site does not allow, because it is very large.

Wernicke's Avatar


Wernicke
10.08.2013 , 06:49 AM | #29
Thank you, downloading updates already gone.

Beesodd's Avatar


Beesodd
10.08.2013 , 06:50 AM | #30 Click here to go to the next staff post in this thread. Next  
Thanks. If it's too large, just include the bottom half(or whichever amount from the bottom will fit).

Edit: sorry if I misunderstand your most recent post, does this mean your issue is resolved?

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.