Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Seeker Droid mission Bugged

Microbia's Avatar

09.21.2013 , 12:14 AM | #1
I done that mission on two characters so i know what to do . But i decided to make anoter char ( whats new ). I did first part (4 seeds) destroyed some imperial base and got a secound part. In this one i need to find 3 seeds , got two of them easily. And the problems begins, becouse i need to find seed on Voss.
When i entered area of this quest my seeker droid prompted me he find someting after a few secounds he prompted me again that he does not see anything intresting in that area . I tried different places in mission area and my seeker droid prompted me several times that he do/dont detects something.
BTW i didnt go beyound borders of mission area.

Microbia's Avatar

09.23.2013 , 01:45 AM | #2
Ok after countless tries to reset/abandon this quest i found a possible resolution.
I finished this quest by joining with my guildmate.
Funny thing is that he also got bugged but my seeker droid worked perfectly
(like nothing ever happend.). I dont know what maked my droid to work, my guildmate or what. Meaby droid is bugging when Voss Loads i do not know