Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Patch has bugged space missions

First BioWare Post First BioWare Post

JewFro's Avatar


JewFro
09.18.2013 , 08:56 AM | #11
My Grade 7 blasters are definitely doing a lot less damage than previously. Either that or the Improved Power Conversion Module isn't working.

Julesmat's Avatar


Julesmat
09.18.2013 , 09:25 AM | #12
I don't know if it's just me, but since the patch I have noticed that the other spaceships seem to require a lot more damage to destroy that they did before. I've been playing the last "Normal" Space MIssion (The Impossible Sector as Republic and Acendancy Barrier as Imperial) for several weeks grinding the rep as I had not the time to practice completeing the HC ones, so I have acquired a good "feel" for how much damage it takes to destroy the mission targets.

Since the patch, it seems to require a lot more effort to complete, the "normal" ships take more blaster fire to destroy, the bonus ships which could be destroyed with 3/4 missiles now need 5/6 and concentrated blaster fire, and the engines for the fighter carriers , 3 or 4 missiles instead of just 2. This with all the upgrades as sold by the Cartel Market. I'm still completing the missions, but its a lot harder than it was and all changed overnight.

Has anyone else noticed something similar?

SydiousSWG's Avatar


SydiousSWG
09.18.2013 , 10:50 AM | #13
It is either the ship equipment or the missions themselves. However, considering this is noticeable on every mission I would lean toward gear or the abilities that modify the gear... Regardless space is broke bad.
Quote: Originally Posted by SydiousSWG View Post
...I might feed trolls once in a while, but not buying them groceries.

AmberGreen's Avatar


AmberGreen
09.18.2013 , 11:10 AM | #14 This is the last staff post in this thread.  
Space Combat silliness update time, listed by individual issue:

1. We've identified a fix that will prevent you from smashing your ship on a giant asteroid that's unavoidable in Taspan Ambush and Syvris Evacuation, and we're testing a fix for it now. I'll continue to report in this thread around those two issues will be closing their individual ones.

2. It's also been confirmed that escort missions are currently bugged such that you're given credit for completing the mission if the escort is defeated. (I have to admit, this bug amuses me.)

3. Additionally, special enemy ships that are missing their health bars has been confirmed and is being worked on as well.

We'll get #2 and 3 updated to the Known Issues, and we no longer need details about them at this time.

4. Finally, we are continuing to investigate problems with damage (both not dealing enough and receiving too much). The details and information posted here are being followed, and we appreciate your continued reports.


Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

Brane_Ded's Avatar


Brane_Ded
09.18.2013 , 02:58 PM | #15
Can confirm that the grade 7 improved power conversion module does not affect blaster damage in #1 key mode. Enemy ships take the same number of blaster shots to kill whether it is turned on or off.
Raging Elitists
The Harbinger, US-West

Highborne's Avatar


Highborne
09.19.2013 , 10:05 AM | #16
Since the latest patch came out, here's a partial list of the problems that I've been having with space missions - and given that I achieved max rank with the Imperial First Mobile Fleet in the first week is was possible to do so (i.e., capped reputation gain every week until I hit Legend) and then continued playing space missions for a long time afterward, I suggest that you don't just brush me off with a "perhaps you're not trying hard enough" response.

Problem #1: Taspan Ambush.

The path in Taspan Ambush now makes you fly THROUGH THE ASTEROID, killing your ship. According to a friend of mine with Republic alts, this is also true of the Republic equivalent.

Problem #2: Kanz Minefield.

The satellite hardpoint seems to be invincible. Normally, I regard Kanz Minefield as one of the easier Level 50 space missions (far less annoying than, say, Cha Raaba Assault), but I just tried to complete it FOUR TIMES and failed, because no matter what I did to the satellite hardpoint, it just wouldn't die.

Problem #3: Less damage generally.

On all missions, I'm finding that my laser cannons are doing about half (or less) the damage of that which I'm accustomed to them doing. What gives, BioWare? Did you slip in a nerf of the laser cannons, or are they simply not working due to a code glitch?

I understand that problems happen, especially in a game as complex as SWTOR - one line of code here stuffs up other ones there, and the like. But if I hear another "You'll have to wait for the next expansion pack to tome out before we address your concerns" (as happened when ship parts glitched out during the last content update before 2.0), then I will be.....most displeased.

DAMossimo's Avatar


DAMossimo
09.19.2013 , 10:31 AM | #17
(removed due to post being compiled into this thread - reads out of context here)

Salemswrath's Avatar


Salemswrath
09.19.2013 , 03:24 PM | #18
Just want to agree with everyone here that the blaster damage is significantly lower than it was before the patch, or the enemy got a big buff. I currently cannot complete the Kabal Station Defense quest due to only being able to kill about 20 of the 30 bombers, and that is full out blasters, missles, and EMP. Before the patch this was one of the easier ones for me to complete. The EMP seems weaker as well, doesn't destroy the larger vessels as well as it used to. The Jedi Ships are also much, much harder to destroy. In Kanz Minefield, same problems, plus, as I think someone mentioned earlier, the health bar above several hardpoints seem to have disappeared.

The power conversion blaster fire seems to be the same regardless of which mode I am in. This is true in the level 50 quests as well as the lower level quests on lower level toons, so regardless of which Grade of equipment I am using.

DAMossimo's Avatar


DAMossimo
09.19.2013 , 06:47 PM | #19
So, unless I'm misreading the situation, you are going to take down the live server tomorrow to fix CZ-198 and a lowbie space mission but leave the Heroic space missions broken until at least Tuesday?

Please tell me this isn't the case. People paid real money to gear ships for the heroic space missions that have been broken just as long (since Tuesday) as CZ has!

The problem is 100% reproduceable and glaring. It should have been looked into when tickets started coming in Tuesday. I gotta say that I don't plan on buying grade 8 ship parts off the Cartel Market to play the fabled "SSSP" if it ever materializes with the track record and attention these space heroics have had given to them.

Shenlon's Avatar


Shenlon
09.19.2013 , 07:22 PM | #20
FYI I was also having a ton of trouble today with New Kovor Ice Field with the same complaints as many others feeling like my blaster firepower was significantly reduced. Remembering back to a time when the level 7 beam generator was bugged, I tried to swap out the old one I had held on to (the 10 shots/sec at 100 dmg/bolt) and tried it again and blew through it with ease.

Previously I had the exact same problem as it seemed like the satellite hardpoint was invincible, however once I swapped to the older beam generator I cleared the mission and all the bonus missions on the first try. For whatever reason, it seems like the beam generator is bugged again. FWIW I made zero other changes, I only changed the beam generator and instantly was able to see a HUGE increase in firepower.

Try it out and report back here since Bioware apparently doesn't test this stuff out very effectively on their own.