Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

looking for more help with my GTX 670 fps issues

STAR WARS: The Old Republic > English > Customer Service
looking for more help with my GTX 670 fps issues

OwenBrooks's Avatar


OwenBrooks
09.06.2013 , 12:27 AM | #11
This is useful info on the CPU for you http://www.anandtech.com/show/4955/t...x8150-tested/4

The Phenom II X6 featured a rudimentary version of Turbo Core without any power gating. As a result, Turbo Core was hardly active in those processors and when it was on, it didn't stay active for very long at all.

Edit - CPU parking will not be cause of 40FPS in a ship though and was just a thought to boost FPS

http://bitsum.com/about_cpu_core_parking.php shows the setting in the power management section but right at the bottom it mentions your CPU as well.

OwenBrooks's Avatar


OwenBrooks
09.06.2013 , 12:34 AM | #12
I would return the Nvidia settings all to defaut in the NVidia control panel and delete and re-add swtor.exe back to your profiles in case a previous change is impacting.

JewFro's Avatar


JewFro
09.06.2013 , 12:37 AM | #13
Im at a much better 95-100 fps on ship now. Something mustve been making my game run very poorly in the background.

I am still getting 15-25 fps in warzones though. And my cores are still being parked. so IDK.

OwenBrooks's Avatar


OwenBrooks
09.06.2013 , 12:54 AM | #14
When you are in warzones does the below affect FPS at all ?

Shadows: Off
Bloom: Off
Character Detail Level: Low
VSync: Off
Textures: Low
Shader: Low

leto_cleon's Avatar


leto_cleon
09.06.2013 , 12:58 AM | #15
Quote: Originally Posted by JewFro View Post
Im at a much better 95-100 fps on ship now. Something mustve been making my game run very poorly in the background.

I am still getting 15-25 fps in warzones though. And my cores are still being parked. so IDK.
Hmm... is it 15-25 fps red (gpu limiting) or green (cpu limiting)?

What I am finding is that in PVE for some strange reason my FPS on Gravity Hook 7 (Imp Side) and Frinn Mesa (Pub side) seems to drop to ~30 fps (red). After some tweaking its about ~40-50 fps (red). The strange thing is I normally get 60 fps (green) almost everywhere else (I'm using V-Sync to limit my fps and am using a 760). So my guess is that there are some optimisation problems in some parts of the game really.

OwenBrooks's Avatar


OwenBrooks
09.06.2013 , 01:03 AM | #16
I too find parts of Makeb I get 45FPS and like you if I have vsynch on, 60FPS green on my GTX670 just about anywhere

JewFro's Avatar


JewFro
09.06.2013 , 01:04 AM | #17
Quote: Originally Posted by OwenBrooks View Post
When you are in warzones does the below affect FPS at all ?

Shadows: Off
Bloom: Off
Character Detail Level: Low
VSync: Off
Textures: Low
Shader: Low
Nope. Thats part of the reason Ive been scratching my head so much. My game runs exactly the same on Very Low-Very High settings.

leto_cleon's Avatar


leto_cleon
09.06.2013 , 01:09 AM | #18
Quote: Originally Posted by JewFro View Post
Nope. Thats part of the reason Ive been scratching my head so much. My game runs exactly the same on Very Low-Very High settings.
Did you the following in the nvidia control panel yet?

Texture Anti-Aliasing - Gamma Correction to Off
Maximum Pre-Rendered Frames to 1
Power Management Mode to Prefer Maximum Performance
Texture Filtering Negative LOD Bias to Clamp

OwenBrooks's Avatar


OwenBrooks
09.06.2013 , 01:11 AM | #19
Just to check what temps do you get on CPU and GPU ? 40FPS in the ship can also be temp related, then it restores when temp lowers, but doubtful if you get 15fps as soon as you enter a warzone though.

Warzones will be the heaviest areas for FPS , does turning nameplates off have an effect at all, this is something I have seen popup occasionally.

JewFro's Avatar


JewFro
09.06.2013 , 01:13 AM | #20
Quote: Originally Posted by leto_cleon View Post
Did you the following in the nvidia control panel yet?

Texture Anti-Aliasing - Gamma Correction to Off
Maximum Pre-Rendered Frames to 1
Power Management Mode to Prefer Maximum Performance
Texture Filtering Negative LOD Bias to Clamp
I have half of those on. I will put on the other 2