Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

GSI Speeders can't be claimed from the Vendor

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
GSI Speeders can't be claimed from the Vendor
First BioWare Post First BioWare Post

ArialBurnz's Avatar

11.03.2013 , 03:57 PM | #11
Okay, this is just plain silly. I read what everyone was saying about having it the cargo hold versus on you and all that jazz...I had all the required parts on me. The vendor said I couldn't afford the item. I went down to the cargo hold, put all the pieces from my inventory into the cargo hold, took them all back out of the cargo hold, including the spares, and put them back into my inventory (so I had 6 pieces total). I kept my inventory open after I closed my cargo hold, went back upstairs to the vendor and tried to purchase it one more time. Lo and worked.

However, my husband's character did the same go. ***? Perhaps I should tell him to do the Hokey Pokey before he tries to purchase? *shakes head*

DarthVengeant's Avatar

12.17.2013 , 05:43 PM | #12
EDIT : Nevermind. Problem solved.