Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher Crashes

First BioWare Post First BioWare Post

GermIIACR's Avatar


GermIIACR
06.25.2013 , 06:23 PM | #1
Was playing game fine last night, after patch today game crashes to desktop after I hit play. I have uninstalled and reinstalled twice today. Then restarted computer. Run as admin, use repair tool and it still crashes after I hit play. I get a black screen for a few seconds like it wants to load then back to desktop. Has anyone else seen this? I'm done for the night, hate to have to reinstall a 3rd time. As I said I was running it fine last night. This happened last year after F2P went live and I think I had to wait for a patch.

Win 7 64 bit
AMD HD 6700
i7 with 8 gigs

Tim-n-Kim's Avatar


Tim-n-Kim
06.25.2013 , 08:17 PM | #2
I started having problems with mine today as well. I get to 8% installed and a problem persists that windows cant fix.

havenasp's Avatar


havenasp
06.25.2013 , 08:39 PM | #3
Quote: Originally Posted by Tim-n-Kim View Post
I started having problems with mine today as well. I get to 8% installed and a problem persists that windows cant fix.
i too am having the same issue. launcher crashes and nothing i do seems to fix the problem.

SlimWhitman's Avatar


SlimWhitman
06.27.2013 , 12:20 AM | #4
Same issue here. I've just updated everything under the sun. I've already spent three days getting through dealing with One Time Passwords which are mailed with all the urgency of a goth on his way to swimming gala. I know have a security key. And I hit play, the screen goes black. And then I'm back at my desktop.

It makes me really glad I signed up for a subscription in order to get around the gods forsaken One Time Password system.

Mundako's Avatar


Mundako
06.27.2013 , 12:31 AM | #5 This is the last staff post in this thread.  
Hi all,

So, there seem to be two different issues here. First, as for the crashing issue, this is something that we are aware of right now and our developers are looking for a permanent solution for everyone. Please take a look at our big thread related to that topic, some users found a workaround which will trigger the repair function, basically re-downloading the asset files: http://www.swtor.com/community/showt...57#post6473957

As for the black screen issue, please open the following folder with Windows Explorer: %localappdata%/swtor/swtor/settings
Move the client_settings file somewhere else (as a backup) and try starting the game again. This should reset all in-game settings back to default, hopefully allowing you to get back into the game where you can re-configure your graphic options.

Please let us know if that helps.
Mundako | Bioware Customer Service - Forum Support

SlimWhitman's Avatar


SlimWhitman
06.27.2013 , 12:51 AM | #6
Both suggested fixes failed, but another option offered later in the same thread and it did work. Thank God for your fans who are busy testing workarounds.

I'd liked to write something vitriolic and wickedly satirical here about the 4 days it's taken for me to actually be able to launch the game, but honestly, I can't be bothered. The level of service would need to improve greatly in order to be merely beneath contempt.

OwenBrooks's Avatar


OwenBrooks
06.27.2013 , 01:06 AM | #7
So want to elaborate which fix worked for you, it may help someone else .......

Lord-Seath's Avatar


Lord-Seath
06.27.2013 , 01:27 AM | #8
Quote: Originally Posted by OwenBrooks View Post
So want to elaborate which fix worked for you, it may help someone else .......
there are two ways currentyl used and described in the above mentioned thread, one was summerised by the User Colatrldamage

Fix:
1. delete assets_swtor_main_version - a 1KB text file in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\Assets
2. run the launcher - there will be an error and the repair process will run
3. It will take about half an hour to full hour to finish
4. download and install will pick up again.

The other one by me and can be read hier

Chose for yourself, good luck

OwenBrooks's Avatar


OwenBrooks
06.27.2013 , 01:31 AM | #9
Cheers, I have never had issues patching myself , just wanted to see if SlimWhitman could mention what helped him as he said the ones above didn't help and I am sure that may help someone else as well.