Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Fix for launcher issues

First BioWare Post First BioWare Post

Calduron's Avatar

06.25.2013 , 12:28 PM | #1

This fix worked for my problems with servers being unavailable. Worth a shot guys!

"Only a single instance of this application can run" Error message.

We have made a file available which should resolve the problem for players who have been receiving the "Only a single instance of this application can run" error when updating the launcher.

Please follow the instructions below to download and install the file:•Go to and download LauncherRepairUtility.exe (the file size is almost 28mb, and it’s a self-extracting 7-zip archive).
•Copy the downloaded file to your SWTOR directory, default locations are below:•Windows 64-bit: “C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic
•Windows 32-bit: “C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic

•Make sure launcher.exe is not currently running on your computer (open your task manager using ctrl-alt-delete, and close any instances of it you find in the list).
•Go to your SWTOR folder (same location as above) and double-click on the LauncherRepairUtility.exe icon. You will be asked to choose a location for extraction of the files, check and make sure it’s pointing to your SWTOR folder, and then click on “extract”.
•The program will ask you to confirm that you want to replace an existing file of the same name. Please click on “Yes to All”.

Once the extraction process is complete, double-click on the new launcher icon to run Star Wars: the Old Republic™, you should now be able to log in without any issues.

We’d like to thank you again for your patience and understanding while we worked on this.

Faeshard's Avatar

06.25.2013 , 09:57 PM | #2
Can we get a full url instead of a link with "..." in it? I get nothing but a "404 not found" with that. Thanks.

Mundako's Avatar

06.25.2013 , 10:10 PM | #3 This is the last staff post in this thread.  
Hi Calduron,

Thanks for sharing and I'm happy that it solved the issue for you! I do believe the actual fix here is to set the compatibility mode for both the swtor.exe and launcher.exe back to default. If the compatibility mode was changed for the launcher.exe in the past, the LauncherRepairUtility tool will correct it by creating a new (fix-)launcher.exe with default settings. The compatibility mode can also be changed manually by right-clicking both .exe files in your installation folder.

@Faeshard The full post from above (including a working link) can be found here:
Mundako | Bioware Customer Service - Forum Support

OwenBrooks's Avatar

06.26.2013 , 01:52 AM | #4
Mind for me with IE that link doesn't work as a single post, you can either right mouse click and select save target as or click this link -