Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

SWTOR Launcher has stopped working

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
SWTOR Launcher has stopped working
First BioWare Post First BioWare Post

jedimasterjacob's Avatar

06.25.2013 , 10:04 AM | #1
Hey there, i'm trying to figure out how to get my launcher working, but it's a different problem than most.

i tried opening it a few minutes after the patch today (6/25/13), and this is what it does: it gets to "installing main assets 120 (8%) and then windows says:
SWTOR Launcher has stopped working
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

although, i haven't tried much. just trying to start it up again and again, and 5 times in a row what happens is the exact same thing above. I've also tried restarting my computer for windows updates (i have windows 8 by the way).

so, if you could give me other ways of possibly fixing the problem, that would be much appreciated. thanks

GerberClimbs's Avatar

06.25.2013 , 10:05 AM | #2
I am having the exact same problem any help would be appreciated.

FrozenCascade's Avatar

06.25.2013 , 10:06 AM | #3
A lot of people have this issue at the moment.
The Spikeyo Series.
Axari Delta.

cdmx's Avatar

06.25.2013 , 10:09 AM | #4
same problem here

Narsimhadeva's Avatar

06.25.2013 , 10:10 AM | #5
Get it together SWTOR what's up?!

Sileriak's Avatar

06.25.2013 , 10:11 AM | #6
I'm also having the same issue, after waiting 30 mins for a OTP

jedimasterjacob's Avatar

06.25.2013 , 10:12 AM | #7
Heh, kinda glad to hear that it's not just me/my computer. hopefully the tech support can solve this issue.

Cerimon's Avatar

06.25.2013 , 10:17 AM | #8 Click here to go to the next staff post in this thread. Next  
Hi All,

Can you let us know if you are all on Windows 8 and if setting the compatibility options for swtor.exe and launcher.exe resolves this.


Cerimon | BioWare Customer Service - Forum Support

cdmx's Avatar

06.25.2013 , 10:17 AM | #9
I am on W7

Glavendale's Avatar

06.25.2013 , 10:18 AM | #10
windows 7