Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Terrible Game Performance After Patch 2.1

STAR WARS: The Old Republic > English > Customer Service
Terrible Game Performance After Patch 2.1

Larry_Dallas's Avatar


Larry_Dallas
06.03.2013 , 02:14 AM | #21
Quote: Originally Posted by myrddinmelana View Post
Examples
On fleet Bank, Mail Box, or any other small clickable loads very slowly. On my system it was immediate now it takes 10-20 seconds after I load fleet.

***Major Issue***
This became very apparent when doing S&V 16 Man HM Boss 7 Dread Master Styrak
*Constantly tanks were reporting the dragon spit was not rendering.... (We used sorc pulls to save tanks)
*Repeatedly members would report rendering issue right after being returned from a nightmare. The raid wiping issue was the 8 force ghosts not rendering for some players. Trying to get in Melee range to prevent obliterate on a mob that has not rendered is a major issue.
*After multiple issue all having to do with things not rendering during the fight we finally killed the Dread Master after about the 5th attempt. We could have one shot it if we didn't have all these problem across 10 of our 16 people in the raid.
Quote: Originally Posted by Seeten View Post
I am one of the tanks in question.

I run an i7 with 12 gigs of ram and an nvidia 670 graphics card. Performance is the same (poor) on both high and very low graphics settings. I ran in high prior to 2.1 with no issues.

Not rendering boss mechanics for 45 seconds is game breaking. please fix.
Quote: Originally Posted by TralyanSavo View Post
I am having serious performance problems since patch 2.1. Most people on my raid team are having the same issues also. I'm having mobs disappear, become unforgettable and continue hitting me. I've had adds not show up on my screen. Long loading times. Ability lag. Mailboxes, GTN terminals, etc not showing up on the fleet for minutes. Framerate issues that make the game borderline unplayable.

Prior to patch 2.1, I almost always had great performance. The difference is really insane.
Quote: Originally Posted by AshlaBoga View Post
Had multiple spheres in 16 Man Operator IX that were invisible for as long as 25 seconds.
There was a Regulator that only half the Operation group could see.

Basically it was a cluster*****
More or less, what these people said.

Marstrike's Avatar


Marstrike
06.03.2013 , 10:35 AM | #22
Yeah i was hit with the same thing too. Have recently done a fresh OS/SWTOR install and still the same.

A game i was running perfectly fine in the highest settings at release in 2011 has got progressively worse performance wise and im starting to lose all hope after all the team is smaller now...

I could go on and be even more negative and rude but i wont. Unsubbed until patch notes contain even a hint of optimization over "heres the armor from swtor videos released in 2008 for x ammount of coins"...

MantecoL's Avatar


MantecoL
06.03.2013 , 01:25 PM | #23
I totally agree, before patch 2.1 was released my game performance was very good, but now its terrible low, sometimes the loading screenshot doesn´t show the image, the hud is buggy an sometimes doesn´t charge and force me to click Ctr+U, and so on. I hope this problems get an answer or better yet GET FIXED!

zaknaphein's Avatar


zaknaphein
06.03.2013 , 01:28 PM | #24
Quote: Originally Posted by Fodiddle View Post
They don't care.
I don't care either lol. I still can't finish patching with this launcher retarded problem. They've got bigger issues to solve and they just don't.

LeeHarveeOswald's Avatar


LeeHarveeOswald
06.03.2013 , 04:52 PM | #25
Quote: Originally Posted by Yper View Post
This is getting really annoying.

I am playing SWTOR on a November 2007 overclocked CPU (Intel Core 2 Extreme QX9650), 1920X1080, graphics settings at very high, and I never had any kind of problem with lag, freezes, slow graphics rendering or whatever else.

The reason the above post annoys me is because ppl like this guy above presume to speak on my behalf (i.e. vast majority of players) whereas in fact I am having no issue whatsoever.

http://www.overclock.net/lists/display/view/id/4640824

^^Link to my system.

In most cases, people who are having performance problems either run the game on non-overclocked CPUS, or low-end CPUs and/or low end GPUs.
"this guy above presume to speak on my behalf (i.e. vast majority of players)" Doesnt that mean you are now speaking on behalf of "a vast majority of players by stating he is speaking on your behalf you effectively claim to belong to that vast majority and by not considering that you might be the minority on whose behalf he is not speaking
let's assume I am 1 of the vast majority, I agree the game has a lot of issues that werent there before last patch, most noptably; random crash to desktop, at least once or twice an hour, and at least 1 or 2 BSOD's a day, only when I play SWTOR
Played WoW a week ago for few days, no crashes, no BSOD's

Rahizm's Avatar


Rahizm
06.03.2013 , 05:23 PM | #26
I also have noticed a difference since patch 2.1. Most noticeable when effects are cast (like Gunslinger's AOE for example). The sounds are louder and in pretty much bad quality, on top of that the FPS is lower. Before 2.1 this was all fine on my end.

So I'm saying it's not just graphics, but sounds too. Want an example? Clear the oasis infiltration to hear a loud BANG. It makes people deaf.

Marstrike's Avatar


Marstrike
06.04.2013 , 08:32 AM | #27
Daily bump

skomerko's Avatar


skomerko
06.04.2013 , 08:42 AM | #28
Dont know why they introduced collections system with knowledge that can introduce severe fps drops... I really really really cant understand it. (we all now the reason)

Icebergy's Avatar


Icebergy
06.04.2013 , 08:44 AM | #29
2.1 definitely has caused a significant increase in load times. I have not had any problems in combat, other than in PvP occasionally. But load in times are significantly worse after 2.1.

Also it is really annoying to have to wait for mailboxes and mission terminals to show up several seconds after I walk over to them.
This signature is a slap in the face!
Mikal'B, Battlemaster and Fleet Commodore of the Republic.
<Contraband Inc> 10/10 NiM, 4/4 NiM, NMP, 3/12 NiM, HM GF, 4/5 NiM
Jedi Covenant

Lorica's Avatar


Lorica
06.08.2013 , 10:01 AM | #30
I am also experience the same exact issues that everyone has listed here. Please fix it EA.

Prior to 2.1, only zoning was an once in a while problem. Now it is much much more debilitating.

EA, how come I do not see all of what is contained in this thread in the updated bug report? Rendering is a huge problem right now. For example, as other people have stated, I can be grouped up and only see half of the targets and none of my companions. I was trying to call off the attack because of this issue but thankfully everything started to appear and were able to finish without any more glitches or any deaths.

I am about to go back to LOTRO and Fallout New Vegas, maybe Train Simulator 2013 if this frustrating problem is not fixed.