Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Problem with low FPS

First BioWare Post First BioWare Post

kingcolt's Avatar


kingcolt
05.19.2013 , 11:48 AM | #11
I have my VSYNC and Tripe Buffering both always on and I have turned all settings down to as low as I can in game. I have also turned my power state to high performance. Its very unfortunate that the SWToR is so unstable but I have done quite a bit of research and there are people that say it is the game but there are others with about the same specs as I have that say they get great FPS, or at least its consistent.

netslayer's Avatar


netslayer
05.19.2013 , 01:09 PM | #12
I have had to turn shadows off and turn vsync off to atleast fix the stuttering issue I had, I dont notice much tearing thank goodness but my fps jumps alot 100 down to 40 randomly fps turning red indicating that I am cpu bound, i am lucky if I even keep 40 fps on fleet, BW still has no input on what the problem is with my system.....
I7 3960x (4.6 ghz) Asus Rampage IV ExtremeCorsair Vengeance 16gb quad channel 1333Ocz Vertex 3AMD Gigabyte 7970Corsair AX1200w PSU

Lilouk's Avatar


Lilouk
05.19.2013 , 04:12 PM | #13
It''s funny how Some people say 'it's your PC' when it is obviously not. The graphics engine for SWTOR (although nice) is piss poor when it comes to utilising what is available.

People with PC's Far beyond the minimum and even more than recommended still get low FPS issues. It's the engine itself, yes some people don't have a good enough System to be able to run everything on max, but other's do but simply can't because the engine is so bad.

I can run BF3 on Ultra settings and Crysis 3 on high Settings at 1920x1080 and have 70/50 FPS respectively, yet when it comes to swtor my FPS take a huge dive.

kingcolt's Avatar


kingcolt
05.19.2013 , 04:27 PM | #14
Ya those are the same things I've found. It would be nice if Bioware would fix this or at least put some sort of effort because it's a big let down.

OwenBrooks's Avatar


OwenBrooks
05.19.2013 , 06:11 PM | #15
Quote: Originally Posted by netslayer View Post
I have had to turn shadows off and turn vsync off to atleast fix the stuttering issue I had, I dont notice much tearing thank goodness but my fps jumps alot 100 down to 40 randomly fps turning red indicating that I am cpu bound, i am lucky if I even keep 40 fps on fleet, BW still has no input on what the problem is with my system.....
Netslayer,
Red is GPU bound not CPU
Some suggestions, not meant to start a debate just pointers on what may help,
Try adjusting your Flip Queue size this should help, lowering reduces input lag but also should reduce the stutter you have, it will depend on your system as this can actually lower fps, going higher can also smooth out the frames and reduce the fps dips you see but may also introduce more input lag, you need to see what works for your system.

As to Vsynch you need to enable triple buffer as well , how you do this with ATI not sure but it does affect D39 games like swtor even though it is for opengl.
quick googling on them
http://www.tweakguides.com/Fallout3_13.html
discussed as Max Frames to Render Ahead in the example link

Triple buffer for ATI
http://forums.steampowered.com/forum....php?t=2876808
http://www.rage3d.com/board/showthread.php?t=33985853

I am Nvidia so ATI I am not that familiar with i'm afraid, hope it helps, but these are the settings likely to help with smooth play, may need to research a bit and use trial and error.

kingcolt's Avatar


kingcolt
05.20.2013 , 02:59 AM | #16
PROBLEM FIXED!!!

So, after doing a little thinking and some research I figured I would try updating my firmware on my TV and it worked! I'm still in disbelief that it could have such a drag on my performance, I went from a max of 60 fps but most of the time about 20 to topping out at OVER a 100 on very low settings and now have it set on medium getting an average of about 25-35 and peaking at 80 during conversations or inside buildings. So for any of you that have a TV hooked to your computer.. make sure you update your Firmware.

Cerimon's Avatar


Cerimon
05.20.2013 , 04:52 AM | #17 This is the last staff post in this thread.  
Hi kingcolt,

Thanks for coming back and posting your resolution, it will be helpful to other players undoubtedly.

Cerimon | BioWare Customer Service - Forum Support