Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game won't run after hiting play on the launcher.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Game won't run after hiting play on the launcher.
 
First BioWare Post First BioWare Post

carvir's Avatar


carvir
01.25.2014 , 10:25 PM | #1131
same issue but gives me error

OwenBrooks's Avatar


OwenBrooks
01.25.2014 , 10:37 PM | #1132
what error ?

jameselsender's Avatar


jameselsender
01.26.2014 , 03:48 AM | #1133
I've installed the launcher on my laptop (while my PC is being repaired) but when I click "Play" the game doesn't run! It appears in the Task Manager for just a second before disappearing...

This is pretty disappointing seeing as I recently had problems with the last patch which resulted in having to completely un-install the game and re-download from the site (took forever!)

Any help/advice would be much appreciated.

Update: I deleted the BitRaider folder as suggested in a previous post but no joy. After trying again several times I got the following error...

"Runtime Error!
Program: c:\programdat\bitraider\brwc.exe
R6025
- Pure virtual function call"

I tried deleting the BitRaider folder again but still not working.

OwenBrooks's Avatar


OwenBrooks
01.26.2014 , 03:55 AM | #1134
Really depends on the system and multiple reasons for not launching

one will be exceptions for launcher.exe and swtor.exe in all AV and firewall exception lists, so knowing OS and AV / Firewall at minimum helps.

Some with Win 8 for example needed to apply directx redist - http://www.microsoft.com/en-au/downl...s.aspx?id=8109

Try a clean boot - http://support.microsoft.com/kb/929135

For future Note you can copy game folders from one system to another and run the launcher directly or just run the setup from www.swtor.com/download over the copied file locations to avoid additional downloading.

edit can also try the below
•Press the [Windows] Key + [R] at the same time.
•Copy the following in to the text box and press ok: %localappdata%\swtor\swtor\settings
•Open the client_settings.ini file and ensure the following are displayed within, or edit/add if so required:
Fullscreen = false
D3DFullScreen = false
RefreshRate = 60

•Save and close the file.
•Start the game as normal.

jameselsender's Avatar


jameselsender
01.26.2014 , 04:09 AM | #1135
For future Note you can copy game folders from one system to another and run the launcher directly or just run the setup from www.swtor.com/download over the copied file locations to avoid additional downloading.

edit can also try the below
•Press the [Windows] Key + [R] at the same time.
•Copy the following in to the text box and press ok: %localappdata%\swtor\swtor\settings
•Open the client_settings.ini file and ensure the following are displayed within, or edit/add if so required:
Fullscreen = false
D3DFullScreen = false
RefreshRate = 60

•Save and close the file.
•Start the game as normal.[/QUOTE]


Cheers dude, running in window seems to have fixed it.
J

DarthJimilingus's Avatar


DarthJimilingus
01.26.2014 , 07:50 AM | #1136
I'm having a similar issue. Perhaps someone can help. I did try and read through a few pages of this first before just posting FYI. Launcher doesn't seem to be working. I click on the launcher. It loads. I enter my username/password. I hit Login. Then a wheel appears next to Login spinning for a long time. Nothing else seems to be happening. I tired making sure its part of the Exceptions in my AV. I tried running as admin. I have windows 7. Not quite sure what else to do at this point. I'm really getting frustrated. I tried completly uninstalling game and re-downloading and installing. I would think it's my Comp at this point but not sure what. Any help would be appreciated.
Level 65 Sith Sorcerer, 65 Jedi Sentinel, 65 Trooper VanGuard, 65 Imperial Operative, 65 Jedi Shadow, 65 Bounty Hunter Mercenary, 65 Sith Juggernaut, 65 Smuggler Gunslinger, 65 Sith Assassin, 65 Sith Marauder, 65 Jedi Sage, 65 Trooper Commando, 65 Imperial Sniper, 65 Jedi Guardian, 65 Smuggler Scoundrel, 65 Bounty Hunter PowerTech. Got them all!

JUANBECDACH's Avatar


JUANBECDACH
12.03.2014 , 05:56 PM | #1137
Just downloaded expansion and game will not start on my alienware laptop after I press play. Please help.

NarroSienar's Avatar


NarroSienar
12.04.2014 , 01:58 PM | #1138
Quote: Originally Posted by JUANBECDACH View Post
Just downloaded expansion and game will not start on my alienware laptop after I press play. Please help.
I have had the same issue on 2 systems since the 3.0 patch... and in doing a search on this form, this fixed both computers (with same problem and vastly different hardware)... make sure SWTOR client is closed first then...

Spoiler


Both times I found that the "Fullscreen = false" line was missing and so I added the line. The first time starting SWTOR the screen started in a goofy smaller window so THEN you go to the preferences in game and change your graphic resolution to something you like for your system.

MAKE SURE that the space on either side of the equal sign is there. I just cut and paste that line in.