Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't start game since 2.1

First BioWare Post First BioWare Post

SonOfSega's Avatar


SonOfSega
05.15.2013 , 10:38 PM | #361
2.1 Update froze mid way through. it then gives you the option to repair files which never works and just sends you on a loop. I have had to remove the game three times now the install is just hanging mid way and then goes to repair files again.

This is happening because of the shotty update and now every one is causing server overloads not to mention interuptions you guys must do for fixes. We are all in the same boat.

My broadband is limited, I am a subscriber we are now talking time and money. Once this issue is fixed please tell us what you will do to make up for this massive waste.

I understand problems happen when you lest expect it but it's up to you to look after your user base.

Windows 7 x64 user

Dirvers upto date

game was running mint before..

marinesusmc's Avatar


marinesusmc
05.16.2013 , 01:03 PM | #362
Same here still having the please repair file error and then it not repair them and break more files to repair.
"There is no problem in the universe that can't be solved with a bribe, a paid assassin, or an overpowered fighter."

Just my 2 credits...

xLagunaNsevenx's Avatar


xLagunaNsevenx
05.19.2013 , 06:46 AM | #363
i have re-installed this game seven times now i'm getting really frustrated since while i'm waiting it'll freeze or restart my computer every time i try. when will this be fixed or how do i fix this myself!!!

ImmortalLowlife's Avatar


ImmortalLowlife
05.19.2013 , 01:49 PM | #364
Quote: Originally Posted by SliderV View Post
Well I don't understand how the servers are all under heavy load since literally thousands of us cannot log in! There ought to be an update screen with the top issue being updated all the time like on other games. At least you would get all of us to stop griping about it!
The server load when I tried to play this morning was" "standard" on every server, but it STILL kept lagging & finally losing the connection within 1min of actually getting to play the game. And I'm running win7. Don't know if it's any better now, but at this point I don't care. I'm canceling my subscription & going back to playing my Wii, 360 & PS3 .
"There is no Light Side...There is no Dark Side...there is only The Force..."

Server: The Shadowlands/ Guild~The Elite Imperial Guard & Order of the Light~

Raetherdal's Avatar


Raetherdal
05.19.2013 , 02:22 PM | #365
Same problem here - two calls into customer support, while helpful they weren't able to solve the problem

SonOfSega's Avatar


SonOfSega
05.19.2013 , 03:25 PM | #366
My fix was selecting windows 7 compatability mode using windws 7 and run as admin, fresh install.

Crazy I know but it got through all the way this was after using 100gigs of my bandwidth tho