Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Can't start game since 2.1

First BioWare Post First BioWare Post

Deadhart's Avatar

05.14.2013 , 09:07 AM | #1
Alright, here's the deal. Since the launcher downloaded and installed 2.1, the game own't start after clicking play. Windows just shows busy cursor for a sec and then nothing happens. The game won't start loading. So... do I need to reainstall?

KopetanchegX's Avatar

05.14.2013 , 09:19 AM | #2
Reinstalling or repairin wont solve the problem. Seems like noone can load into the game

DragonXmate's Avatar

05.14.2013 , 09:20 AM | #3
same problem with me, i click play and the game srceen comes up but thats it, never come up to the character selection

gunslinger's Avatar

05.14.2013 , 09:21 AM | #4

opened game, patched, clicked "Play" Launcher disappears, but game does not come up, even to loading screen.

Tried reboot of computer. Tried Repair Scan. Still does not come up. Task Manager does not show that SWTOR application or process is running.

Deadhart's Avatar

05.14.2013 , 09:24 AM | #5
Aw come on. Especially now, when then added something I can finally spend my hoarded cartel coins on. Hope it's resolved by 19:00 CET for I have an ops with ma guild then

palamax's Avatar

05.14.2013 , 09:28 AM | #6
working now ppl, just wile was about to write that is not lol, waited a little anyhow

Beesodd's Avatar

05.14.2013 , 09:30 AM | #7 Click here to go to the next staff post in this thread. Next  
Hi guys,

Just to be clear, the 2 issues appear to be separate. For players who are getting a load screen, please wait, and this should drop of after 7-10 minutes (not ideal of course, and we're looking into why there's such a wait).

If you're getting no game screen at all, do you get a flash before everything disappears? Also, please check your Reliability Monitor to see if there's any reference to a game crash within that time frame. To do so open the search box and enter "view reliability history". In the tool that appears, search for a red "X" with a reference to swtor.exe, and include that info in a reply.

Sorry for the inconvenience casued, and thanks for the reports.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

dvrocc's Avatar

05.14.2013 , 09:32 AM | #8
pretty sure when my launcher patched it mentioned the servers will be back up at 10am well its currently 8:32am atm xD

Deadhart's Avatar

05.14.2013 , 09:33 AM | #9
No, there is no flash or anything. Just a bit of processor buzzing like usual when it's doing something, busy windows cursor, and then nothing. Swtor.exe does appear on task manager and then just silently disappears

BardaViccal's Avatar

05.14.2013 , 09:35 AM | #10
Dont even know what a reliability monitor is (windows xp)
So for people getting to loading screen they just wait.
Us folks who cant even launch the game just stuck in limbo?