Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The launcher is being updated. Please wait...

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
The launcher is being updated. Please wait...
 
First BioWare Post First BioWare Post

haliy's Avatar


haliy
05.09.2013 , 12:43 PM | #1
So I was half way threw HM Cademimu when I ended up being DC'd due to my wifi signal being interupted. Whatever... it happens. I restarted my wifi router and all is well with my connection again.

I closed out the game because it could not get a good server listing when i tried just logging in straight off the server selection screen. I then attempted to start the game from scratch and the patch server could not be found so i run the Fixlauncher.exe file and now, I am at the login page where the Launcher seems to want to take forever (takes an excess of 20 minutes without stopping).

Tried to close the launcher and restart it and every time, the launcher will not finish updating.
MOSAIC - JEDI COVENANT
Guild Website
Haliy - 55 Sentinel ~ Windigo - 55 Shadow ~ Kája - 55 Sage
Vindeta - 55 Commando ~ Snapshote - 55 Operative

Beruthien's Avatar


Beruthien
05.09.2013 , 04:53 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings haliy,

Could you please go to www.swtor.com/download, download the latest launcher setup file and run the installation over the current one? After this please flush the DNS cache and then try again.

Please come back to us if the issue remains after this.

Thank you!
Beruthien| BioWare Customer Service – Forum Support

CBODETTE's Avatar


CBODETTE
09.26.2013 , 12:03 PM | #3
I have done both download and reinstall along with the DNS cache fluching and i am still having the launcher is being updated problem

Bronholz's Avatar


Bronholz
09.26.2013 , 12:29 PM | #4 Click here to go to the next staff post in this thread. Next  
Greetings CBODETTE,

Thanks for contacting us.

Have you tried the Launcher Repair utility? You can find the steps here.

Thanks for your patience.
Bronholz | BioWare Customer Service – Forum Support

GefjonAsgard's Avatar


GefjonAsgard
09.26.2013 , 12:42 PM | #5
I don't believe this.

After 48 hours waiting for the Launcher to patch I got it working this morning. I played for about an hour.

Now I have arrived home ready to play for the evening and ..........................



.................... Launcher being updated, please wait!!!!


*** are you people doing?

Ktama's Avatar


Ktama
09.26.2013 , 01:16 PM | #6
This is beyond incompetence, you can't even get your game to work and you want to compete with wow ? LOL

CBODETTE's Avatar


CBODETTE
10.02.2013 , 05:31 PM | #7
i have run the repair tool three times plus done three complete re-installs including dns cache flushing and nothing is working. If this does not stop pretty soon i will be requesting a refund on my most current subscription fees.

Beruthien's Avatar


Beruthien
10.02.2013 , 05:34 PM | #8 This is the last staff post in this thread.  
Greetings CBODETTE,

Could you please do a Clean Boot and then run the repair utility again?

If the issue remains, please come back to us with your most recent Launcher log.

Thank you!
Beruthien| BioWare Customer Service – Forum Support

KayalDraknys's Avatar


KayalDraknys
01.26.2014 , 11:22 PM | #9
Ok....I just got a new computer since my old one didn't have a strong enough processor to run the game without INSANE lag during ops. It only came in Windows 8. I selected your "download client" option. Installed no problem. I open the Launcher. I put in my user ID, password, and security key code. I click "Launch". I see the loading circle to the right come on. That's it. That's where it stops. Stayed that way for the entire night. What the hell? I went into properties and changed compatibility to Windows 7, since it doesn't have a Windows 8 option. But it worked in 7 on my other computer. Still stays that way. SO, I try to close it. I have to manually go into task manager to shut it down. Then it comes back up and seems to be updating, as I get the "The launcher is being updated. Please wait..." message. That too stayed up an entire night and NOTHING updated. WHAT THE HELL?!?!?!?!?!
You are free to sever the chains of Fate that bind you...

-Kayal, The Awoken-

OwenBrooks's Avatar


OwenBrooks
01.26.2014 , 11:55 PM | #10
Exceptions for launcher.exe and swtor.exe in AV and firewall is the first thing , known issue with NOD32 if you use that AV. Also known issues if using bitdefender

You can also try the repair utility - http://www.swtor.com/community/showt...hp?t=419492#98

You could also try under a clean boot - http://support.microsoft.com/kb/929135