Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher freezing on repair

First BioWare Post First BioWare Post

ChewyYui's Avatar

04.26.2013 , 12:23 PM | #21
Nope! No issues apparently, and the game still won't install
The Progenitor - The Alteric Legacy - Kira-chan

Cerimon's Avatar

04.26.2013 , 12:45 PM | #22 Click here to go to the next staff post in this thread. Next  
Hi ChewyYui,

Please run the System File Checker from Microsoft as this can find problems with your system files and repair them:

Cerimon | BioWare Customer Service - Forum Support

ChewyYui's Avatar

04.26.2013 , 01:10 PM | #23
Thanks, I'll try it. Also, is there anyway I don't have to keep re-downloading Main Assets 115 when I try to install the game, or after a repair in the installation? It's 5gb and I have a download limit (I've had to download it 4 or 5 times already)

EDIT: Completed the scan, the only things that weren't fixable were listed as optional things, or sound files

EDIT 2: The Issue is with Main Assets 115 I'm sure of it. It constantly freezes when installing it, and when I have to repair, it is the same files "broken" as before I redownloaded the game
Assets/swtor_main_anim_creature_a_1.tor,Assets/swtor_main_anim_creature_b_1.tor,Assets/swtor_main_anim_humanoid_bmns_1.tor,Assets/swtor_main_anim_misc_1.tor,Assets/swtor_main_area_alderaan_1.tor,Assets/swtor_main_area_balmorra_1.tor,Assets/swtor_main_area_belsavis_1.tor,Assets/swtor_main_gfx_1.tor in
That was the last attempt before my current one. I also found this
INFO ManifestState=Patch: assets_swtor_main, current=0/upcoming=-1/required=114
2013-04-26 18:21:39 ERROR Corrupt Source detected in C:Program Files (x86)Electronic ArtsBioWareStar Wars - The Old RepublicAssets/swtor_main_anim_creature_b_1.tor ( (e5)
2013-04-26 18:21:39 ERROR File info: size=193681916, created=4/25/2013 16:50:50, accessed=4/26/2013 4:50:4, written=4/23/2013 1:0:58
In the same log for the cycle as the above.
The Progenitor - The Alteric Legacy - Kira-chan

Cerimon's Avatar

04.26.2013 , 02:27 PM | #24 This is the last staff post in this thread.  

Please see the following from our Launcher Troubleshooting Guide:

If Repair does not work and you consistently receive “corrupt source” or “unknown file” errors in your Launcher logs (these can be found in the “\logs” directory in your install directory), please try the following, in order:
  1. Run chkdsk
  2. Run Memtest86+
  3. Disable overclocking of CPU and/or memory
  4. Confirm the CAS Latency setting of your memory in BIOS is correct
  5. Confirm the voltage setting of your memory in BIOS is correct
  6. Update your Ethernet drivers
  7. Update your virus scanning software
While some applications are tolerant of minor file corruption, the SWTOR Launcher is not. The incremental patching process it uses is extremely bandwidth efficient but requires that the source and patch files be pristine to correctly apply the patch. Corrupt source and unknown file errors in the logs indicate that the Launcher has determined there are errors in the source or patch file which would prevent the patch from being cleanly applied without causing instability in the game.

The only reproducible causes for these errors that we’ve found to date have been either file system issues or memory issues. This is why we urge users to run chkdsk and memtest86+, and check their BIOS settings. It is completely possible for a system to appear stable in normal daily use and still have memory or disk issues that prevent SWTOR from patching. That said, these errors can ultimately lead to general system or data corruption so getting them fixed is in your best interest if you are affected.

Please let us know if your issue remains and we will try to assist you further.

We apologize for any inconvenience caused.

Cerimon | BioWare Customer Service - Forum Support

ChewyYui's Avatar

04.26.2013 , 06:04 PM | #25
Thanks, it seems that (I think) after running the scan you suggested before, the cycle that the launcher was currently on, was successful, and I now am able to play the game again. If I have any more issues with patches, I will try what you posted above.

Thank you again
The Progenitor - The Alteric Legacy - Kira-chan

Zandaric's Avatar

04.27.2013 , 05:27 AM | #26
Ok, I had pretty much the same issues. I had not played for two months and when tried to start the game it failed patching and I had to run a repair that froze up. I found that my C: drive had some repairable errors on it.

To make a long story shorter... I ended up doing a check disk with the scan for errors and repair option set. This did not fix the problem even though it fixed my Hard Drive Issue. I verified the drive was good with a scan tool from the manufactures of the Hard Drive

I ran memtest86 + (You just have to download the ISO version and burn it to a CD or DVD). It found no issues at all.
I uninstalled and reinstalled to another Hard Drive and it still froze. I tried all the suggestions listed here (to the T and even dotting the I(s)) where you download the launcher setup and patch in safe mode with networking. That also did not work.

So, I Downloaded WinMD5.exe and started making a copy of all the asset directories and files and computing codes for every file. I found that most of the files I had to download more than once matched but every once in a while one would be corrupted. I ended up figuring out which ones were good and collected them. I decided to do a fresh install one more time.

It was at this time after uninstalling the game that I chose to reboot. Even though my system was testing good and not overclocked very much I set my PC to run at normal speed. I also set my video card to it's normal speed. I also removed my GTX 570 video card and noticed it's heat sync was almost completely clogged with dust (so I removed the cover and cleaned and unclogged it). I then started reinstalling the game and copied the asset files I collected into the install directory when it would start trying to download them.

This time it did not freeze and I finally got to play the game again. I'm not sure exactly what was causing it to freeze. I had my system overclocked like this for two years and I ran extensive testing on it to be sure it was stable. Also it is not over clocked very much at all. Also it was over clocked the first time I installed this game.

I do know from the MD5 codes that for some reason some of the files I was downloading had somehow gotten corrupted. There had not been any patching going on at that time so I see no reason that the files would have been changed. The main file I saw that seemed to be getting corrupted was "assets_swtor_main_0to112.z01" I had downloaded the files in the directory "assets_swtor_main_0to112" many times and I ended up with four copies of the file listed above all with different MD5 codes. I finally ended up two of the files that generated the same code and then I knew I had an uncorrupted copy of it.

Anyway, I'm just glad that my nightmare with this is over and that I can finally play. I hope that somehow this information helps somebody who is still dealing with this problem.