Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Lag/Latentcy issues? READ ME!

STAR WARS: The Old Republic > English > Customer Service
Lag/Latentcy issues? READ ME!
First BioWare Post First BioWare Post

T-Assassin's Avatar


T-Assassin
04.17.2013 , 02:22 PM | #1
BW/EA has to be aware of the ongoing lag, latentcy, and connection issues on servers such as The Harbinger. These issues are NOT user end connection issues, that has been proven. tracert, ping, in-game monitor has provided the evidence.

For a majority of the users experiencing this, there are servers available to them that provide better, suitable performance. Yet, there has been nothing done to address these issues, other than it be the responsibility of the paying customer to create a new character on one of the better performing servers.

This of course does not take into consideration the time, effort, and value of what the already paying customer has invested in their account. And, most, if not all, of these server issues(transfers) were forced upon us, at least in all of the cases I am aware of, including my own. (I had little to ZERO lag, latency issues, WZ performance issues on the server I CHOSE at launch (MZL).

Through no fault of my own, my investment was forced onto another server, The Harbinger, and I have had this connection issue (the midwest Comcast/Harbinger issue). 106-109ms connection with constant 574ms spikes, peaking at 3000ms+, at least hourly.

However, there are servers available to me that allow me to enjoy my game without issue. One of them being The Shadowlands. I can play for continuosly and stay at 35-36MS with 60MS MAX peaks.

I called CS today to request a character transfer or get my money back for the lack of services rendered, through no fault of my own. I was on the phone for 1 hour and 27 minutes (have a phone screenie as evidence) only to be told, by P4-Q1 (who was very polite, tolerant, and as helpful as she could be) "There is nothing I can do for you."

This is unacceptable!! How did my investments go from a server that was performing adequately, to one that's performance is unacceptable. Again, through no fault of my own. I could not even participate in warzones due to the lag/latentcy. As a server first Battlemaster (yeah I puffed up a bit ), PvP and server performance is paramount!

As a paying customer, I will no longer accept NO as an answer. Either A. transfer my characters to a server of MY selection or B. refund my funds from when I was forced onto an inadequate server.

I am requesting a formal response, either from a developer or BW/EA employee and as I have stated, "NO" will be unacceptable. Server merges are possible, that is how my investment was affected to begin with.

I will continue to persue this until myself and others that were affected have received a proper compensation. (Server merges is a start...You could probably charge for them! I just gave you an idea to increase revinue this quarter!!)


If others have a similar situation, or agree, please sign and share your experiences.

Thank you,

Dissatisfied Customer
"Ib'tuur jatne tuur ash'ad kyr'amur."
"Today is a good day for someone else to die." -

Nokecity's Avatar


Nokecity
04.17.2013 , 02:34 PM | #2
I agree...on MZL I was straight but now its bad at certain times, and I have to have Comcast also (**** sux). This weekend was horrible dude, running Lv 55 HM FP during boss fight I would go from 100% to 0% in like 5 secs and the whole time Im thinking im at full health. I think the funniest this with the lag is how my Force Scream looks like im about to sneeze but does'nt want to come out (LOL).

Oh yeah TA, I retired from PvP

Denchet's Avatar


Denchet
04.17.2013 , 02:41 PM | #3
Its not just a midwest Comcast issue. I am constantly having routing issues as well and I live in California. My guildmates up in Washington have the same issues (also on Comcast). Comcast and SWTOR (at least on the Harbinger, I would assume all West Coast servers) just don't work well together. Week long routing issues seem to pop up every couple of months.

And good luck trying to get Comcast to fix it on their end, their customer service will have no idea what you are talking about if you mention trace routes. Can't switch ISP either because they have a monopoly in my area.

What has to happen is BW/EA need to get in contact with the ISPs that are having these constant routing issues and tell them to fix their crap. I know Comcast is one of them, I've seen people complaining about other ones as well.

T-Assassin's Avatar


T-Assassin
04.17.2013 , 02:42 PM | #4
Quote: Originally Posted by Nokecity View Post
I agree...on MZL I was straight but now its bad at certain times, and I have to have Comcast also (**** sux).

Oh yeah TA, I retired from PvP
I HAD to quit PvP! on MZL I was a BOSS!! (you know :P )

on The Harbinger, in WZ's 150ms+, 600ms spikes, 1-3 sec ability delay.

PvE is only acceptable because it is so easy and predictable, I can plan ahead and adjust my game for the expected lag. That is what i tried to explain to P4-Q1 today over the phone.

I was moved, FORCED out of PvP, the major contributing factor to my playing of SWTOR. Was forced out of PvP'n, and really, hanging out with you guys, cuz I was relegated to PvE.

It's like taking your car into the shop and when you get it back it only goes 45mph.

sure, you can drive it, but you can't take it racing with your buddies(PvP). and some days it sputters like crazy, even at 45mph!!

UNACCEPTABLE!
"Ib'tuur jatne tuur ash'ad kyr'amur."
"Today is a good day for someone else to die." -

T-Assassin's Avatar


T-Assassin
04.17.2013 , 02:44 PM | #5
Quote: Originally Posted by Denchet View Post
Its not just a midwest Comcast issue. I am constantly having routing issues as well and I live in California. My guildmates up in Washington have the same issues (also on Comcast). Comcast and SWTOR (at least on the Harbinger, I would assume all West Coast servers) just don't work well together. Week long routing issues seem to pop up every couple of months.

And good luck trying to get Comcast to fix it on their end, their customer service will have no idea what you are talking about if you mention trace routes. Can't switch ISP either because they have a monopoly in my area.

What has to happen is BW/EA need to get in contact with the ISPs that are having these constant routing issues and tell them to fix their crap. I know Comcast is one of them, I've seen people complaining about other ones as well.
I agree, but I could not speak for west coasters.

thank you for your input!!
"Ib'tuur jatne tuur ash'ad kyr'amur."
"Today is a good day for someone else to die." -

criminalheretic's Avatar


criminalheretic
04.17.2013 , 02:54 PM | #6
/signed
What we don't understand, we can make mean anything.
Hyperspace Cannon -> Drooga's -> The Harbinger

SWBaltazar's Avatar


SWBaltazar
04.17.2013 , 06:19 PM | #7
The Harbringer has been unplayable for me for the past 2 days. My latency just ping-pongs all over the place. One minute it will be less than 100, the next its 800 or even 30k.
Sanguis---Marauder
Clem-------Power Tech
Wezli-------Sniper

Denchet's Avatar


Denchet
04.17.2013 , 06:20 PM | #8
Just reporting that this is still happening today. Started 2~ hours ago. This morning it was fine, presumably because the load on whichever routers are breaking wasn't as bad. I can forget about playing properly during prime time though.

BKBNero's Avatar


BKBNero
04.17.2013 , 06:43 PM | #9
Honestly, until the 2.0 patch came out, lag was not an issue for me. Since 2.0 dropped, I can hardly play for five minutes before I start having major lag issues, and then eventually get booted for a connection error. You'd think with this game F2P, yet EA/BW raking in more money than ever from Cartel Coin purchases, that they might look at character transfers for subscribers or, you know, opening up more servers again (because that makes total sense, right?). Nope, at least not that we've (the paying customer) been made aware of. So I'm forced to swallow my rather large investment (17 characters worth, don't judge me) and look at starting over on another server. At least until EA/BW unf*cks itself. I'll probably have 17 50+'s on a new server by then...

...yay
I see what you did there

Morbuss's Avatar


Morbuss
04.17.2013 , 06:45 PM | #10
Im having terrible lag since 2.0
Im on the jedi cov. server and the lag is making the game almost unplayable. I have comcast but my internet connection is fine and my other mmo games run fine.