Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher Issue: Corruption. About to give up.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Launcher Issue: Corruption. About to give up.
 
First BioWare Post First BioWare Post

James_Dunril's Avatar


James_Dunril
12.20.2011 , 09:31 PM | #11
Be great if they fixed this.

Xavium's Avatar


Xavium
12.20.2011 , 09:37 PM | #12
I'm using the same client that used to work yesterday, but no longer works. The symptoms I have are the same as yours - log in, click Play, load for 3 seconds, crash to desktop (no error message).

It's a pretty serious issue when you can't play on launch day at all.

I use win XP btw.
Yippee!

Hunterkat's Avatar


Hunterkat
12.20.2011 , 09:38 PM | #13
Quote: Originally Posted by Blackstang View Post
lol why would you wipe your HD for a game? Do you know what you are doing? You obviously did something wrong if it worked before and does not now.
actually I think the main problem is not in the files themselves but in the launcher. I played in the early acess for several days before I started having trouble. It was after they updated the launcher that I started having problems. Now I'm in the repair/downloading main asset 19 loop. There almost has to be something wrong with the launcher.

NightseeR's Avatar


NightseeR
12.21.2011 , 05:07 AM | #14
Had this problem too, a reinstall didn't help, but it's working perfectly after running FixLauncher from the game folder.
"I aim to misbehave."
"May have been the losing side. Still not convinced it was the wrong one."

Weeber_OWE's Avatar


Weeber_OWE
12.21.2011 , 05:12 AM | #15
Getting same issue I installed using the discs and don't even have a repair feature.

This along with my friend's security question issues and they really need to allow you to return the game for your money back. I know it being an EA game it was just a cash grab like all EA games but I thought I could at least get a good month out before they ruined it.

Meadale's Avatar


Meadale
12.21.2011 , 05:16 AM | #16
Dunno if this will help, but once you install it from the discs, go back and download their game client. It'll update the launcher.
This is what worked for me.

Weeber_OWE's Avatar


Weeber_OWE
12.21.2011 , 05:29 AM | #17
Quote: Originally Posted by Meadale View Post
Dunno if this will help, but once you install it from the discs, go back and download their game client. It'll update the launcher.
This is what worked for me.
Thanks, worked for me.

G-Shrike's Avatar


G-Shrike
12.21.2011 , 06:06 AM | #18
If you don't want to download the launcher again you can go into settings on the login page and change the language to French. Save and allow it to extract files and when it's done change back to English. Suprisingly this worked for me. I had no repair option on the launcher and tried all other types of fix but this is the only thing that worked.

RussianRob's Avatar


RussianRob
12.21.2011 , 08:26 AM | #19
Saw this on another forum, I thought it makes sense to try some of this stuff as its pretty simple methods to troubleshoot. Good luck everyone.

Possible Solution #1: Disable fullscreen mode

Go to your the folder where you installed Star Wars: The Old Republic (SWTOR)
Look for the file client_defaults.ini and open it
Press Ctrl+F search for the following line: FullScreen=true
Change ‘true’ to ‘false’
Restart Star Wars: The Old Republic (SWTOR)
Possible Solution #2:

Run Star Wars: The Old Republic (SWTOR) in administrator mode. To do this, right-click the .exe or the desktop shortcut of Star Wars: The Old Republic (SWTOR) and select ‘Run as Administrator.’
In case you can’t do above, In XP or Win7, you can also create a new windows profile with administrator access, (name it whatever you want) then find the launcher in explorer and run the game.
Possible Solution #3:

Update your Java software. Check our Technical References for the proper links to the Java Updates.

Possible Solution #4:

Turn your in-game resolution a notch down (1280×800 would be good). Star Wars: The Old Republic (SWTOR) should work smoothly now.

Possible Solution #5:

Make sure you installed Star Wars: The Old Republic (SWTOR) in your main C: Drive with sufficient space.

Possible Solution #6:

Make Star Wars: The Old Republic (SWTOR) recreate your local game data by deleting: C:/Users/…/AppData/Local/

Problem #3 Star Wars: The Old Republic (SWTOR) Crash Fix – Various Star Wars: The Old Republic (SWTOR) Crashes, APPCRASH Errors, SWTOR has stopped responding

You may be experiencing one or more of the following crashes and errors:

RemoteRenderer.dll Crash
Blue screen / Black screen
nv4_mini.dll
MSVCR90.dll
If so try the applicable solutions in found above in Problem #2. You may also try running through our list of general fixes, or proceed to Problem #4 solutions below.

Problem #4 SWTOR Error Fix – Internal Error ABORT: Pointer is null (.socket.c/385)

Simply disable your firewall, or alternatively add SWTOR.exe and launcher.exe to your firewall exceptions list.

Problem #4 Star Wars: The Old Republic (SWTOR) Crash Fix – Crash to Desktop upon Launch / Startup

If you’re game randomly crashes upon launching the game, ensure or try the following:

If you played or participated in the Beta, make sure you have fully uninstalled the SWTOR Beta before attempting to install the full version.
Update your nVidia / ATI graphics drivers. Check our Technical References page for download links.
Turn off SLI / Crossfire
Turn off your anti-virus software before launching the game, but make sure you turn it back on after playing.
Try using only one GPU first (turn the other one off via your graphics control panel)
Try running the game in Windowed Mode (usually works for low-end PCs)
Disable anti-aliasing and filtering
Disable V-sync
Disable background apps, and turn off your anti-virus software
Run through our list of general fixes, which will most likely resolve your problems
Problem #5 Star Wars: The Old Republic (SWTOR) Crash Fix – For Quad Core PCs

If you’re on Quad Core, try this fix to address any crash issues:

Start the game
Alt+Tab Out of the game
Open Task Manager
Right click on Star Wars: The Old Republic (SWTOR).exe
Set Affinity
Select core 0 and 1 only. You need to run the game on two CPU’s basically, so to avoid the crash to desktop.
Problem #6 Star Wars: The Old Republic (SWTOR) Install Error: “Star Wars: The Old Republic (SWTOR) Install Fails, Cannot Install”

This is a Microsoft C++ bug so the quick fix is to uninstall your C++ files. If you see 2 instances of Microsoft C++, uninstall both of them; and don’t worry, they are easy to reinstall. There are also a couple workarounds online if you don’t want to uninstall them.

Problem #7 Star Wars: The Old Republic (SWTOR) Game Freeze Fix – Game Freezes during the Intro Video

If you’re using Steam, a quick solution is to verify the integrity of your Steam game cache to resolve the problem. If it persists, ensure that both your graphics drivers and DirectX are updated. Doing both will mostly reduce the occurrences of Star Wars: The Old Republic (SWTOR) freezing.

Problem #8 Star Wars: The Old Republic (SWTOR) Crash Fix – Game crashes when launching / upon launch

This is a typical DirectX problem. Just update to the latest DirectX version and voila. If that doesn’t work, reinstall DirectX completely.

Problem #9 Star Wars: The Old Republic (SWTOR) Graphics Fix – Cannot see main menu, Menu crashes, Dual monitor problems

A common problem when playing on multiple screens. For now, the solution is to unplug other monitors and play on single screen. If that doesn’t work, try playing in windowed mode.

Problem #10 Star Wars: The Old Republic (SWTOR) Crash Fix – nVidia Optimus Crashes the Game

If you’re using a newer laptop that’s using an nVidia Optimus card, try checking your Optimus settings.

Open the “nVidia Control Panel” from your start menu.
On the lefthand side, under “Select a task…”
Open the “3D Settings” tree, and select “Manage 3D Settings”
On the righthand panel, click the “Program Settings” tab.
Under “1. Select a program…”, click “Add”, navigate to your installation folder and navigate to the application / exe file.
Under “2. Select the preferred graphics…”, choose “High-performance NVIDIA processor”
Then (VERY IMPORTANT!) click “Apply” in the bottom right.
Launch the game.
Problem #11 Star Wars: The Old Republic (SWTOR) Sound / Audio Fix – No sound or weak sound

For Windows 7 and Vista users:

First of all, update your sound card drivers. If doing that doesn’t clear up the problem, make sure you have volume set to max for Star Wars: The Old Republic (SWTOR) in the volume mixer (click on the little speaker icon in the bottom-right of your screen in the system tray). If you’re in-game, just alt+tab out of the game and check if Star Wars: The Old Republic (SWTOR) is set to max in the volume mixer.

Another tip you could try is to go to Control Panel > Hardware and Sound > Sound > Communications Tab then select the “Do Nothing” radio button to permanently fix this issue.

For Windows XP users:

Reduce hardware acceleration, or set your speakers to Stereo.

Beti's Avatar


Beti
12.21.2011 , 12:43 PM | #20
I have the same problem.

Tha game crashes to desktop before even the main menu shows. Loading image, then crash to desktop. The mentioned solutions don't work.

The beta played fine, but the final product isn't? I played Crysis 2, MF3 and new gales like them without a problem, even this beta and now this? WHY? It starts on even my PoS laptop, with minimum settings and terrible lag. But why not in my PC?

Problem Signature: APPRASH
Application Name: swtor.exe
Application Version: 1.0.0.0
Application Timestamp: 4eebb070
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.17514
Fault Module Timestamp: 4ce7b96e
Exception Code: c0000008
Exception Offset: 00081f24
OS version: 6.1.7601.2.1.0.256.1
Locale ID: 1038