Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Space Mission Achievments not working correctly

STAR WARS: The Old Republic > English > Flashpoints, Operations, and Heroic Missions
Space Mission Achievments not working correctly

Kalendorin's Avatar


Kalendorin
04.11.2013 , 04:17 PM | #11
I called Bio-ware and in the process of getting a run around ( I can only assume they have no clue) what I have determined is the space missions among other things will not be fixed and achievements will be unavailable until April 14th when RotHC goes live...this is speculation only, do not take this as a confirmation or denial from Bioware as they would not give me a definitive answer

PalmTrees's Avatar


PalmTrees
04.11.2013 , 06:13 PM | #12
Glad it's just not me. Ran into all the same problems when I tried to finish up the space achievements last night. I'm sure it'll get fixed soon. bwhaha. made myself laugh.

Cupelixx's Avatar


Cupelixx
04.11.2013 , 06:23 PM | #13
Quote: Originally Posted by Sykomyke View Post
I just attempted to get the Clouds of Vondoru and Aeten Defense Mastery achievements.

I completely decimated all Republic Frigates in Aeten Defense (destroyed every targetable component) but the frigates do not blow up (like they do in the new Heroic Space missions). As such, they don't count as being "destroyed" by the mastery achievements.

In Clouds of Vondoru, I destroyed every gun emplacement, shield generator, and Bridge, (every targetable component) and was not counted as destroyed the Republic Capital Ship.

As of right now, some of the achievements are bugged, or were not coded correctly (maybe even both).

I'll update as I try other achievements.

List so far:
Clouds of Vondoru Mastery - Defeat the Capital Ship 0/1 (NOT WORKING)
Note: I destroyed every targetable part of the ship.
Aeten Defense Mastery - Defeat the Republic Frigates 0/1 (NOT WORKING)
Salacumi Fleet Action Mastery - Eliminate Fighters 0/1 (NOT WORKING)
Note: I destroyed every fighter in this mission and still did not get the achievment.
Cartel Listening Station Mastery - WORKING
Nez Peron Sweep Mastery - WORKING
Sarapin Assault Mastery - Defeat the Capital Ship 0/1 (NOT WORKING)
Ezran Outpost Mastery - WORKING
Taspan Ambush Mastery - WORKING
Jabiim Escort Mastery - Disrupt Enemy Communication 0/1 (NOT WORKING)
Mugaar Ice Field Mastery - WORKING
Skaross Fortification Mastery - Defeat the Republic Frigates 0/1 (NOT WORKING)
Sullust Interception Mastery - Decimate Republic Forces 0/1 (NOT WORKING)
Polith Minefield Mastery - Clear the Minefield 0/1 (NOT WORKING)
AND Decimate Light Fighters 0/1 (NOT WORKING)
Ascendency Barrier Mastery - Clear the Minefield 0/1 (NOT WORKING)
AND Decimate Light Fighters 0/1 (NOT WORKING)
I'm pretty sure most of these never worked. Pretty awesome that they put the achievements in and didn't even verify that they were properly attainable.
Please un-break Slicing lockbox missions.

mattchanner's Avatar


mattchanner
04.11.2013 , 07:53 PM | #14
bump, I killed everything literally everything in one mission and I still didn't get the bonus achievement
U MAD? Let go of your Anger.
Look I made a Dumb fan video too
http://www.youtube.com/watch?v=USRec...el_video_title

exdseptu's Avatar


exdseptu
04.12.2013 , 01:23 PM | #15
Seems Bioware has a thread of "Known Issues" and it seems this is in it;

Players are currently unable to complete the “Jabim Escort Mastery” Achievement due to not being able to complete the “Disrupt Enemy Communication” goal.

So they do recognize there is a problem, but limit it to one mission.
Here is the thread:
http://www.swtor.com/community/showthread.php?t=403398
"A jack of all trades, is a master of none."

Karamazovmm's Avatar


Karamazovmm
04.12.2013 , 04:21 PM | #16
Essentially I agree on the pub side, its the same thing, impossible things to complete are displayed like Fondor Escort you need to blow a comm tower, there are no space stations

or impossible sector that demands you to kill fighters while there is no corresponding mission, unless they are talking about the heavy ones which I have completed several times and still it doesnt grant me the achievement.

MorgothPl's Avatar


MorgothPl
04.13.2013 , 10:27 AM | #17
Yep, lots of them not working both on Republic as on Imperial side. It's a shame, because that blocks getting cool titles.

Also, I tried to thest few theories on those achievments with "old". Went for Archenar Interception where it says "disable destroyer (old)" Tried to to it on the character level, you usually get them, in grade 1/2 ship mods. Didn't count. Run it again, guns only, as for the first time I used missiles on turrets. Also didn't count for achievment.

Darwiniann's Avatar


Darwiniann
04.14.2013 , 09:28 PM | #18
I just don't get how the developers could miss so many glaring errors in the legacy system. All of the missions have been run millions of times, yet no one caught multiple problems?

CommanderKeeva's Avatar


CommanderKeeva
04.15.2013 , 03:48 AM | #19
What's up with the "old" tags next to some bonus missions? Does it mean that they were doable at some point but the missions were taken out later and became obsolete?

Also, why aren't the heroic space missions in there somwhere in the space section? If you get an achievement for shooting down 20 weak fighters in the first mission, why don't you get anything for finishing Thanium Disruption/Cha Raaba Assault, which is easily the hardest space mission in the game.
BEING A GOOD SOLDIER COMES DOWN TO ONE THING, ONE SINGLE QUESTION:
WHAT ARE YOU PREPARED TO SACRIFICE?

Morphlingx's Avatar


Morphlingx
04.18.2013 , 09:43 PM | #20
Le bump, I don't want them "forgetting" this.