Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

No love for security question issues.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
No love for security question issues.

TheForlornVigil's Avatar

12.20.2011 , 07:00 PM | #1
So this started on Friday 12/16/11 during EGA when I got a notification to enter a secure question but upon entering it in the login launcher, it said it was invaild. I tried to see if I could get around it by going on the main swtor site and changing it but that didn't work either. A quick hotfix I found was to reset my password and log into the site which allowed me to log into the game.

That worked for only so long though. Come Sunday morning 12/18/11, I logged in like normal at 11am and played until about 3pm then came to log back on at 5pm to experience the same problem. After not being able to log in and trying my personal hotfix it still failed to work. I decided to finally call Costumer Support and the lines were busy to the point that I wasn't even reassured by being put on hold, just hung up on by a bot. I figured after reading a bit on the site and on twitter that this was a known problem and part of a reset or patch of some sort in regards to the launch the following day. So I gave up for the night after sleeping in 3 hour intervals ever 18 hours throughout the EGA and got some much needed sleep.

I tried once again to log in at 10am on 12/20/11 to find the problem still persisting and tried once again to call costumer service to no avail and failed hard once again. Went to school and came back to find the same thing come 4pm the same problem has been persisting for the last 4 hours of calling and hanging up. This isn't a problem with not being able to connect, graphics bugging me, Taris making me stuck on the planet, or no product code. I was able to play all weekend but come day before launch and day of, I am not even capable of doing anything but logging into the site to ask for help from another player that may have experienced the same issue. My question is, despite costumer services bot telling me this is a resolved issue showing me that they are aware of such things happening, what can a guy do to catch a break?

TL;DR - Security questions locked me out of logging into the launcher and pleas to developers on twitter get ignored, costumer services doesn't answer besides a bot, and emails will be answered the same way. How can I get back to playing the game?

Thanks to anyone even willing to read this wall of text let alone offering some insight or help!