Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Really Awful Performance/FPS on Makeb

STAR WARS: The Old Republic > English > Customer Service
Really Awful Performance/FPS on Makeb

spectreclees's Avatar


spectreclees
04.09.2013 , 05:53 PM | #11
Not to mention the really awful lag. They're going to be in trouble when everyone else is able to be on Makeb.

Rogoo's Avatar


Rogoo
04.09.2013 , 06:07 PM | #12
And by the way. A CS reply asking you to post your Dxdiag, then update your drivers, then undust your fans and whatnot - does NOT count as an "official response".

We already had plenty of those. And the official response is still "it's your low end rig".
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

TaafeMJ's Avatar


TaafeMJ
04.09.2013 , 06:08 PM | #13
Yeah, combat slows it down to where it's unplayable. Even simply walking around in safe areas with only a couple other people, I experience framerate drops.

ironikkiller's Avatar


ironikkiller
04.09.2013 , 06:22 PM | #14
problem with all that is they dont do enough instances that why the planet is so bad they have all these player on and but not enough instances i mean comon sort it out

Rogoo's Avatar


Rogoo
04.09.2013 , 06:41 PM | #15
Quote: Originally Posted by ironikkiller View Post
problem with all that is they dont do enough instances that why the planet is so bad they have all these player on and but not enough instances i mean comon sort it out
Are you serious ? There are like 60 people on my instance. Republic and Imperial. On the WHOLE planet.
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

Floredon's Avatar


Floredon
04.09.2013 , 07:35 PM | #16
im thinking it has something to do with the water rendering, specifically the waterfalls. when i get near one i notice a drop in performance.

ArcSky's Avatar


ArcSky
04.09.2013 , 07:56 PM | #17
I'm not even in the Makeb area. I am on Tatooine with a load of 62 players and I continually experience lag as well as drops to the main log in screen.

Daynja's Avatar


Daynja
04.10.2013 , 01:54 AM | #18
Its pretty shocking that in 2013 an MMO is updated with an EX-PACK and it goes backwards in performance.
I would really like to see them work on the engine above all else to include a better 32bit exe running on mutli cores and even better than that a 64 bit client that allows for OS and larger ram configs to be used properly.

I wanted this game to get better and because it hasnt had the financial backing from millions of subscribers i like many have supported the game with many cartel purchases adding to the coffers so to speak. I would hate to see the employee numbers dwindle even further because thats got to be one of the core reasons they cannot dedicate as much time to real fixes to the core of the game.

As it is now BW i cannot play your new EX-PACK because its an eye sore and it makes me feel queezy with 10-15 FPS on Makeb on this system im using (details posted at beginning of the topic).

Rogoo's Avatar


Rogoo
04.10.2013 , 01:35 PM | #19
I went from averaging the usual 40(ish) frames per second during combat to 25(ish) on Makeb.

Lowering details does not seem to affect things.
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

DaKnuckles's Avatar


DaKnuckles
04.11.2013 , 10:13 AM | #20
Quote: Originally Posted by ironikkiller View Post
problem with all that is they dont do enough instances that why the planet is so bad they have all these player on and but not enough instances i mean comon sort it out
I was playing on a instance that had 8 players on it and not a one around me and still had the lag/fps drop lol