Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Help!

Gogri's Avatar


Gogri
04.06.2013 , 01:26 PM | #1
Since the Customer Service forum, or whatever you want to call it, is significantly lacking a sense of helping people for some reason, I will post this in the Community category.

My friend cannot play this game, he would also be posting this but he can't, because it is not allowed for him to.
Here is the issue:
My friend installed the game, for the first time, recently, and after the initial loading screen and the first cut scene he pressed the "escape" key, which crashed his game. Afterwards, he tried running the game again, and instead of getting to the cut scene his game crashes at the initial loading screen, no messages, no warnings, nothing.
My friend then looked through many threads, sites, anything for help, but nothing helped, he also tried repairing the launcher. After my friend's SECOND install of the entire game, it seemed to be working, but at the first cut scene, again, he pressed the "escape" key and his game crashed, and it is the same thing.
I hope someone in this forum can be of some help, because in the clearly identifiable "Customer Service" category of threads, nobody is of help, this is ridiculous.
Thanks.

AlexDougherty's Avatar


AlexDougherty
04.07.2013 , 05:01 AM | #2
It seems to be some sort of compatability issue, we would need more info to help, like what's his computer running on, what else has he got running, etc.

Also I will suggest he stops pressing escape, if he needs to go to the next screen press "Space".
Peace can be found, above all passions. Through passion, I may gain strength.
Through strength, I may gain power. Through power, I may gain victory.
But for every enemy fallen, a new foe rises.
For every chain broken, new chains bind me. Only the Force can set me free.