Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Crashing on Launch/Loading

Tom_Joad's Avatar

04.05.2013 , 05:33 AM | #1
Please help,

My game is crashing on launch. I followed the steps in the sticky. I also went so far as to re-install the game. In addition I found logs:

Scenario: Re-installed the game and came back the next morning (Launcher.exe never closed) and pressed "Play". This brought me to a screen with no servers or characters.

The next three are from me trying to start the game.


Ran the launcherfix.exe

The only in-game setting I changed between when the game showed an empty server list and when the game was crashing on launch/loading was I changed from full screen to windowed. I couldn't find a settings file in which I could change it back. Perhaps that is the problem?

I've been paying for this game since it came out, and would like to be able to play again.

OwenBrooks's Avatar

04.05.2013 , 05:45 AM | #2
Set your swtor shortcut to run as administrator

•Press the [Windows] Key + [R] at the same time. (The [Windows] key is the key with the Windows icon on it)
•Copy the following in to the text box and press ok: %localappdata%\swtor\swtor\settings

First up try simply deleting the client_setting file and it recreates on startup

otherwise the below from false to true on fullscreen will swap you back to fullscreen.

•Open the client_settings.ini file and ensure the following are displayed within, or edit/add if so required:
•Fullscreen = false
•D3DFullScreen = false
•RefreshRate = 60

•Save and close the file.
•Start the game as normal.
•Change graphic settings within the game as desired.

Stormpenguin's Avatar

04.05.2013 , 06:29 PM | #3
The exact same is occurring with me, and I am receiving the same error. I used to be able to run the game without issue, but as of recent I decided to get back into the game before the release of the new expansion, however I am receiving this consistent issue with my game. While I didn't have an issue with the servers as the OP did, I am consistently crashing every time I launch the game.

I have attempted changing my settings, and this did not fix anything. I ran the SWTOR fix and after scanning and 'fixing,' the same problem occurs. I have updated all of my drivers to the latest version, however this shouldn't be an issue if the game was capable of running previously. I would love it if this could be fixed as soon as possible. I've been wanting to get in on the double XP weekend and eventually be involved in the early access for the expansion, but it's looking grim at the moment.

ZillaElite's Avatar

04.05.2013 , 10:19 PM | #4
I had the same problems. I was running it as administrator but for some reason I was running it in XP compatability mode as well. Once I turned off compatability mode, the crashing stopped and it's running fine.

Stormpenguin's Avatar

04.05.2013 , 11:05 PM | #5
I appear to be not running in compatibility mode, but thanks for the suggestion regardless.

Edit: Actually, I decided to try run it in compatibility mode, and now I'm not crashing at start up. Yet to see if this induces crashes later on in the game or not, but so far so good. I ran it in Windows XP (Service Pack 3) for those interested in trying it themselves.

alexanderlutsky's Avatar

04.07.2013 , 09:06 PM | #6
I started having the same problem, as described here after two things happened, near each other
1) Latest patch (1.7.3a)
2) Latest nVidia drivers for my GeForce GTX 260 got updated

Triad all the methods mentioned in this thread, none worked. Waiting time for the phone support is 45 minutes. Can't log in to the game to submit ingame ticket. Isn't there an e-mail somewhere of the Customer Support? Very frustrating, current level of support is, hmmmm

alexanderlutsky's Avatar

04.07.2013 , 11:09 PM | #7
Nevermind, I was able to fix the problem.
What I did was updated my chipset nForce drivers to the latest version. Somehow during the process, nVidia Control Panel decided to stop loading at windows startup (the green icon at the right taskbar no longer appeared - although it might have been some other component of nVidia driver than Control Panel)
After that game ran just fine. I take it the graphics presets this latest nVidia driver had for SWTOR are bugged