Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher Update Problem

First BioWare Post First BioWare Post

FrozenDevil's Avatar


FrozenDevil
04.03.2013 , 07:42 PM | #1
Ok, so i go to play SWTOR and the Launcher starts up normally for a few seconds but then it has that red thing at the top and says "Launcher is being updated, please wait" or something like that, so i let it do its thing, then it closes and comes up with a pop up thingy saying "Only a single instance of this application can run" so i click "ok" and it doesn't do anything and when i try to open SWTOR again it does the same thing over and over, any help would be appreciated.

Stopdamadness's Avatar


Stopdamadness
04.03.2013 , 09:51 PM | #2
11:50pm EST here and having the same problem so I guess this has been going on for some time. All I know is they need to get their **** right before xpac or I'm out.

Sivrron's Avatar


Sivrron
04.04.2013 , 12:17 AM | #3
Same problem.

BuffoonButcher's Avatar


BuffoonButcher
04.04.2013 , 02:23 AM | #4
Here we go again. This company cannot even do fundamental updates. People rip on windows OS, but at least I can still use my computer after an update. I am NOT going to mess around with this or that trying to get it to work. It gets fixed by Friday morning or I am done. Great game when it worked. How can Bioware put out a superb game like Mass Effect 3 and then put this crap out? Enough said. I am going to play some old fashioned Thief2 now. Even the patch after 15 years worked just fine.

THEREALWARGASM's Avatar


THEREALWARGASM
04.04.2013 , 02:52 AM | #6
....

Quote:
Bronholz
Old 04.02.2013 , 04:38 PM | #2 Click here to go to the next staff post in this thread. Next
"Only a single instance of this application can run" Error message.

To help us while we look into this issue we would like to request some information from you.

Before this there are some steps that we want to make sure you have tried. Please see the details below and if you haven't tried these steps please do so now:

Confirm that no instance of launcher.exe is running by opening Task Manager and selecting the processes tab
Confirm that neither a “patch” nor “patcher_-1to64” (or any directory with #to# in the title) is present in the SWTOR directory
Restart PC
Launch SWTOR (do not attempt to login until patch process completes)

If you are still experiencing the same issues please try the below:

Run fixlauncher.exe
Restart PC
Launch SWTOR

Also for the users who are stuck with the launcher updating, due to the Single Instance error, please see below:

Open the Task Manager and select the processes tab.
Run the launcher and let it update
When it has finished this please check the Process tab to see if the launcher.exe process stays
If it does please End the Process.

If you have done all of the above and you are still experiencing the same issues please Run Launcherdiag and send the output to support@swtor.com. In this mail please list all the steps that you have tried, please try to be as detailed as possible and include your symptoms i.e Crash to Desktop, blank server selection or single instance error message.
Spoiler
Go to the game files, by default you will find them here:

Windows 64-bit: “C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic
Windows 32-bit: “C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic

Here you will find a tool name 'launcherdiag.exe' this will collect together your DxDiag, MSINFO and pack them into a .tgz file.

After running the application you will see a new file called “diag<number>.tgz”(“<number>” will be replaced with an actual number) in your SWTOR folder.

Please can you attach this file in a mail to the support address.
Thanks for your continuing patience.
Um, No.

Do your job and fix this.

Klaux's Avatar


Klaux
04.04.2013 , 03:07 AM | #7
Well I have this problme now too. Can anyone get into the game?

This is ridiculous now!!

OwenBrooks's Avatar


OwenBrooks
04.04.2013 , 03:16 AM | #8
Quote: Originally Posted by Klaux View Post
Well I have this problme now too. Can anyone get into the game?

This is ridiculous now!!
Patch for me went smooth, zero issues, Win 7 64bit i7 3930k and 670GTX

FrozenDevil's Avatar


FrozenDevil
04.04.2013 , 08:51 PM | #9
"Confirm that neither a “patch” nor “patcher_-1to64” (or any directory with #to# in the title) is present in the SWTOR directory"

this actually worked for me

Panama_jax's Avatar


Panama_jax
04.05.2013 , 08:11 PM | #10
I am having the same problem as well. And SWTOR, don't thank me for my patience. I have none. You are wasting my time and money.
Why does it even matter WHO SHOT FIRST!?!?!?!?