Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR Crash to Desktop on Launch

STAR WARS: The Old Republic > English > Customer Service
SWTOR Crash to Desktop on Launch

Zionite's Avatar


Zionite
03.26.2013 , 05:04 PM | #1
So I've tried a variety of fixes over a week to diagnose my issue and so far nothing has helped. The problem is: crashing immediately to desktop upon pressing "Play" from the launcher.

Some details:
  • Fresh install of SWTOR from swtor.com installer.
  • Running SWTOR launcher.exe and swtor.exe in Windows XP SP3 Compatibility mode as Administrator.
  • Fresh install of OS - Windows 7 Home Premium 64 bit.
  • Drivers updated with AMD's autodetect tool and Driver Genius' scanner.
  • DirectX installed from here, DirectX functioning appropriately in other DirectX games (tested on Civilization 5; options for both 9 and 11).
  • .Net framework updated from here, and also through Steam's auto .net framework installations on first-run games.
  • Latest version of Quicktime is installed and updated.
  • No overclocking or tinkering with default Catalyst Control Center settings.
  • Ran both fixlauncher.exe and repair within the launcher.
  • No reliability report available as this is a crash without a visible error. This isn't "Swtor.exe has stopped working", this is a crash without error.
  • Memtest86+ came back clean.
  • Windows Update has nothing to update.
  • DxDiag:
    Spoiler
Hints:
There are some troubleshooting things I've done that may point us in the right direction in the diagnosis. My first issue was just frequent crashes to desktop, every 10-20 minutes or so. I tried creating a new Windows 7 User account to see if that changed anything. I found that it started crashing immediately on pressing "Play", instead of letting me play for 10-20 minutes. This is the same issue I have now with a clean OS installation. This leads me to believe that the intro videos are preventing my launch, and even skipping those videos will inevitably make me crash later, so it's a symptom rather than a problem.

On a separate hard drive, I installed Windows XP 32-bit, updated drivers, installed .net framework, directX, and Quicktime. This met with success. I was able to play for a few hours with no issues at all. This told me my problem was with my OS or some other configuration. It also means there is nothing wrong with the SWTOR client, unless it has compatibility issues with Windows 7. My next step was reinstalling Windows 7 64-bit to a new partition, which is where I am now. (As a side note, my XP partition is no longer running SWTOR due to another problem: Direct3D not available in the dxdiag).

A clean OS installation did not solve my problem, and I'm running out of options. Even after taking the steps above, I'm still not able to play. It's very frustrating and a huge time sink in tinkering rather than playing. All my other games run without issue, and I'm finding it harder to justify playing SWTOR over other games.

Anyway, if any of the forum users have a fix I haven't tried, I'm ready and willing. I also encourage any CS representatives to help out if they can. But I could do without the canned responses with fixes I've already tried; new ideas only please.

Zionite's Avatar


Zionite
03.27.2013 , 01:24 AM | #2
Bump.

OwenBrooks's Avatar


OwenBrooks
03.27.2013 , 01:49 AM | #3
Just tossing up thoughts
Trying to refresh my memory now, crash on launch points more to driver/hardware issue if not a corruption issue where fixlauncher and the repair on laucher doesn't find errors.

Can you post up a list of programs that are normally running in the background ?

No overlays used in-game ? mumble, steam etc

Installing quicktime is a old workaround to replace missing files for example in .net

Did we monitor temps ?
temps will be higher in swtor then civ 5, and 10-20 min is about right for heat issues to start appearing.
Not sure why Xp would not be the same though in this case.

Zionite's Avatar


Zionite
03.27.2013 , 06:59 PM | #4
Thanks Owen,

So my startup programs are very few due to reinstalling. Here's the list from msconfig.
  • Logitech SetPoint
  • Steam Client Bootstrapper
  • Java(TM) Platform SE Auto Updater 2 0
  • Apple Push
  • Quicktime
  • Catalyst Control Center

Normally the Steam overlay is fine, but just in case there's something wrong with it I always test first with the regular launcher generated on installing. So I've ruled out the Steam overlay as the cause.

Temps are something I've been keeping an eye on, and the only thing I've tried adjusting in the CCC. I turned up my fan speed from 20%, in increments of 10%, to 70%. I didn't notice any difference when I was crashing every 10-20 minutes and the temp stayed in the 30-36C degrees range. And like you said, if it was an overheating issue then we would have problems on XP too.

OwenBrooks's Avatar


OwenBrooks
03.28.2013 , 12:46 AM | #5
Run msconfig and disable startup items for now.
Crash on start may be different to the in-game 10-20 min crash

if not able to start yet
•Press the [Windows] Key + [R] at the same time. (The [Windows] key is the key with the Windows icon on it)
•Copy the following in to the text box and press ok: %localappdata%\swtor\swtor\settings
•Open the client_settings.ini file and ensure the following are displayed within, or edit/add if so required:
•Fullscreen = false
•D3DFullScreen = false
•RefreshRate = 60
•Save and close the file.
•Start the game as normal.
•Change graphic settings within the game as desired.

OwenBrooks's Avatar


OwenBrooks
03.28.2013 , 12:50 AM | #6
Run this http://www.ozone3d.net/benchmarks/fur/ see if it crashes

Hamidox's Avatar


Hamidox
03.28.2013 , 06:26 AM | #7
one of my friend had to format hdd just to fix this problem. We tried every possible solution but didn't fix that crash problem until format. Even now he's having the same problem occasionally. at least not often that used to be. ( He was getting crashes every 15-20 min before format )

Zionite's Avatar


Zionite
03.28.2013 , 04:40 PM | #8
Great ideas guys, thanks.

@Owen: Furmark is great. I've never been able to test my graphics card like this. Here's some snapshots I took. What I found was that, as my temperature increased, my fan speed would increase to accommodate the changing temp. It capped out at 70C degrees and wouldn't push past that. That dip you see in the chart of the first image is where I turned off the fuzzy render. The second image was taken after turning the fuzzy on, then the postFX on. My fan speed never exceeded 50%, which means my 70% test runs were excessive.
What that tells me is that there's no reason this GFX card can't run SWTOR smoothly on max settings. There may still be a driver issue, but nothing is wrong with the card.

My client_settings.ini were a definite honeypot. But I didn't find entries for "fullscreen =". Here's what they look like now:
Code:
[Renderer]
Buckets = 3
D3DFullScreen = false
GraphicsDeviceId = 26685
GraphicsQuality = 3
Height = 1024
MeshLODQuality = 1
NativeHeight = 1024
NativeWidth = 1360
PerfTestFlags = 31902720
RefreshRate = 60
SpeedTreeDistanceScale = 1.25
TextureAnisotropy = 16
Width = 1360
CodeVersionChanged = true
LastCodeVersionRun = 1
NewBucket = 3
Changing the D3DFullscreen to false allowed me to play the intro videos, albeit very bad quality with screen glitches and sheets of green. I used ESC to skip them, and got hung up after that. No login screen, just black or loading screen freeze. Task manager reports swtor as still running. Then I realized I left out RefreshRate. Changing that to 60 allowed me into the login screen!

So I haven't played much yet but I'll do some testing with this to see if I still get the 10-20 minute out, but I'm ecstatic we made it this far! SWTOR CS needs to start paying OwenBrooks for this.

OwenBrooks's Avatar


OwenBrooks
03.28.2013 , 06:21 PM | #9
Once your in-game you should be able to adjust the gfx how you want them and click save and you should be able to login fine from that point and play.

Zionite's Avatar


Zionite
03.28.2013 , 06:33 PM | #10
Well I am still getting the CTDs unfortunately. So lets keep the solutions coming.