Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Black Talon....crash?

First BioWare Post First BioWare Post

DrewFromPhilly's Avatar

03.01.2013 , 05:53 PM | #11
I don't follow the idea that its our computers, because I distinctly remember a time many months ago when esseles, black talon, and foundry all worked completely fine for me.

Clonecak's Avatar

03.03.2013 , 06:54 AM | #12
For an old bug try and old work around. Before where you normally DC...I am assuming that you DC after selecting the option to return to space station or DK....Ensure that you are in Windowed mode, select your option and immediately Alt-Tab to windows screen. Wait til you hear the jump to light speed end, you will hear your rewards drop...then Alt-tab back to SWTOR you should be on a load screen...Hope this helps.

Eyesmindassassin's Avatar

03.03.2013 , 07:39 AM | #13
Definitely not a computer problem. Worked fine months ago until a certain patch and then the crashes started occurring. Also happens on different CPU's. My computer is new and a complete monster. Built it myself. More than enough to run this game and better than 99.9% of computers out there. This bug is far worse for Republic/Esseles, though. When you get DC'd there, you do NOT get credit as the quest does not complete right after. Even still, really annoying bug that needs to be fixed ASAP.

Eillack's Avatar

03.03.2013 , 09:57 AM | #14
Quote: Originally Posted by CourtneyWoods View Post

I wanted to jump in here and let you know that Eric has confirmed that we made some improvements to crashing issues in the latest patch, but we are aware that this issue may still occur and we are actively working on fixing this.

Hope this helps! Thanks!
It's been "may occur" for almost the entire game's life.

Thank you for trying to fix it though.

Kowack's Avatar

03.08.2013 , 08:45 PM | #15
I think its a video card driver issue. I had never had a crash issue with the black talon mission until the last couple of weeks. Now it crashes every time. In fact I have never had a crash to desktop in this game until recently. Now that I think about it...... my galactic map is not blacked out anymore while on my ship, so it may be an in game setting that was changed after the last patch that has to do with graphics. I have 2 6950's in crossfire, so its not a lack of processing power.

manchusabre's Avatar

03.15.2013 , 05:20 PM | #16
Yeah kind of disappointing that this has been happening for months now on black talon and esseles. I remember not having these problems with the game. I have to wonder why the gameplay is getting worse instead of staying the same or getting better. You still get knocked through the floor on esseles by the tractor beam console. This glitch has been in the game for over a year now. I remember falling through the floor in February of 2012.

SlimsPicken's Avatar

03.18.2013 , 04:45 PM | #17
The black talon crash was still affecting me as of last night.

My workaround is:

windowed mode (full)
shadows off

with these settings I can complete the one conversation point (the warp point) that causes the crash.
For every man there is a sentence, a string of words, which has the power to destroy him.

ayobreezie's Avatar

03.18.2013 , 07:25 PM | #18
Quote: Originally Posted by SlimsPicken View Post
The black talon crash was still affecting me as of last night.

My workaround is:

windowed mode (full)
shadows off

with these settings I can complete the one conversation point (the warp point) that causes the crash.
I got'a try this.. 'cause turning off bloom doesn't work for me. Shadows I could care less about.. but bloom makes it look so much better.
Pull up to the scene with my saber missin'! Middle finger up to my competition!

JamieKirby's Avatar

03.19.2013 , 04:21 AM | #19
Quote: Originally Posted by DarthGile View Post
Bad news: It's a client crash in a game that's been out for a year and 2 months.
Good news: When you log back in, you still receive full credit and the quest completion window is waiting for you on either Dromund Kaas or Fleet.
Not when it crashes for me, anyway, i have to play in full fullscreen and ALT-TAB into windows while the scene plays out, so it doesn't crash.

Bioware need to fix this, the lack of it being fixed just shows how lazy they are.

NSStember's Avatar

04.04.2013 , 02:26 PM | #20
Quote: Originally Posted by Shwarzchild View Post
Are you sure it's not your computer?
Absolutely. This began after 1.2 and I know in my case the came cuts out at the end of Black Talon and Esseles but no other Flashpoint, all the way up to the end game level 50's. But even to this day both of those still "crash" at the end scene. In a group it's not so bad, you log back in and complete the mission. But it keeps you from ever running them alone.