Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Crash after hitting play

First BioWare Post First BioWare Post

Ezrat's Avatar

01.08.2013 , 01:58 PM | #1
I hit play and go to the usual black screen while it loads the splash screen. It sits at this black screen for a minute or two (longer than usual) then crashes to desktop. No error popup. Nothing in the event logs other than a generic application hang error.

This worked fine until the patch. How do I fix it?

Bronholz's Avatar

01.08.2013 , 02:08 PM | #2 This is the last staff post in this thread.  
Greetings Ezrat,

Thanks for contacting us.

Please try re-downloading the latest version of the launcher and setup files from here.

This has been known to resolve issues such as this.

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

Ezrat's Avatar

01.08.2013 , 05:10 PM | #3

I saw that one coming so well that I uninstalled and started patching after my original post.

I tried running FixLauncher prior to that and it did not work. I sure hope downloading 30GB of game data fixes it....

+1 to you for not making me wait a week for my canned response though.

DarthMat's Avatar

01.08.2013 , 05:44 PM | #4
I was having that problem today too. I repaired the launcher and all was well in the galaxy.

Ezrat's Avatar

01.08.2013 , 08:49 PM | #5
Complete reinstall of the game and it still crashes. I am updating my drivers, but I have not made any driver changes in the past month when this was working fine...

Another patch, another break.

Ezrat's Avatar

01.08.2013 , 08:56 PM | #6
For the sake of arguement I tried just running that patcher install and it did fix it. I'm not sure why it did and a complete reinstall did not, but ill take it.