Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Security Question Problem

Ormow's Avatar

12.13.2011 , 12:46 PM | #1
So i picked 3 simple question which i cant forget........

My current pet

My street (which i lived on my entire life)

and my City

well i got the question about the street i typed it in and ERROR WRONG!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! so i tried a Capital first letter in the start & ERROR!!!!, then it got locked out i reset my password multiple times to try the security question multiple times and i also tried the answers to my other questions so frankly something has bugged on your end i sendt a support form 10 hours ago and i haven't gotten any response. i really really hope its not such rubbish support cause frankly out of principle id pass on Subscribing on this game even if i paid 65 Euros for it, it looks awesome but that ain't all you know! i also tried calling and i just get busy busy busy busy, im 1 frustration nerve away from just trashing this entire awesome game.

ArcShenku's Avatar

12.13.2011 , 12:48 PM | #2
Yeah... I'm stopped at the security question too. It is asking me a question I never selected, so I can't logon to the game. I try to call the Support Number (US) and am told that the number is out of order.....
Black Sun Mercenaries|Jedi Covenant|Empire Sniper
No combat ready unit has ever passed inspection. No inspection ready unit has ever passed combat.

ericgib's Avatar

12.13.2011 , 02:08 PM | #3
If you know you have autocomplete on, you can always make a dummy account -> get to the security questions and look in those fields to see what you had entered. I was having this issue this morning and I did this and found out I have miss typed one of my answers.