Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

I'm a current subscriber yet my account when I log in acts like I am not...

STAR WARS: The Old Republic > English > Customer Service
I'm a current subscriber yet my account when I log in acts like I am not...
First BioWare Post First BioWare Post

Roalmo's Avatar


Roalmo
12.12.2012 , 04:53 PM | #111
Quote: Originally Posted by AmberGreen View Post
Thank you for your continued reports. We deployed a fix for this issue with patch 1.5.2, which resolved the issue for most players. However it seems that there are still a few people being affected...


Just to be clear, this issue manifests as a player who has been logged out as Subscriber or Preferred Status Player (often triggered by the account being left AFK). ...
Strange mine happened only AFTER 1.5.2 was deployed.

And after I logged out for a brief break, i.e, I did not go AFK.

NobleAuger's Avatar


NobleAuger
12.12.2012 , 10:23 PM | #112
1. Orry
2. The Ebon Hawk
3. Republic Fleet
4. Since December 3rd.

Loss of quickbar set up, loss of speeder piloting 3, etc

Wyvernblade's Avatar


Wyvernblade
12.13.2012 , 06:03 PM | #113
This happened to me today.

Myrick
The Shadowlands
Defender (Jedi Knight)
December 13 6PM Central

It set guild master to someone else as well as reset all of my hotbars. A log in and out fixed it. I did step away idle I think on character select and came back to being logged out.

I did send a bug report.

Cinthorc's Avatar


Cinthorc
12.13.2012 , 06:45 PM | #114
Quote:
11.20.2012 , 06:13 AM | #4
REPORT POST QUOTE
It took another two login tries to get my subscriber status back in-game.

However this brings up a HOST of issues.
My quickbars went away and when they did get back - I had to spend 30 minutes reslotting all my abilities. Not exactly what I want to do when I play a game.
My vehicle skill downgrades. And when subscriber status comes back I have to pay to train my vehicle skill back up again. This is also b******t.
My STAP deleted itself from my abilities tab. Luckily it came back when I got my subscriber status back in the mail. But still. I am pretty sure deleting my vehicle is not cool.

My biggest complaint about this is the UI features. The quickbars are a basic UI function - a necessity to play your game and yet you are charging free players for them. It's a very poor and sad move. It engenders a distrust and basic wariness of the quality of the game that feels the need to nickel dime people for essential gameplay USER interface elements. Imho you should have left the 4 quickbars and added 2 for subscribers but removing them? A horrible move. And obviously causing a problem for me and other subscribers when they DISAPPEAR and force us to reslot all our abilities when we manage to get them back.
12/12/2012
Apx. 13:00 CST
Anathar
LVL 50 Jedi Guardian
The Harbinger

Just adding that this very same problem happened to me as well, including the host of issues mentioned above. After logging out and quitting, then restarting the game my character was back as a subscriber but quick-bar slots were empty and Digital Deluxe items were missing until mail later came in.

When I saw everything was missing and I had to use Cartel Coins for hide head slot and such I was simply SHOCKED!! Yes, I was fortunate to quickly remedy the error but it troubles me greatly that something like that happened and may happen again.

AmberGreen's Avatar


AmberGreen
12.17.2012 , 10:19 AM | #115 This is the last staff post in this thread.  
Thank you again for your reports. We have identified what is causing this issue and will be implementing a fix in a patch after the first of the year.
Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

MikeTheSempai's Avatar


MikeTheSempai
12.21.2012 , 09:02 AM | #116
Posting this for a friend of mine:

Q. Character name.
A. Devill-dono

Q. Server name.
A. T3-M4

Q. Area logged in to (ie. Republic Fleet, Voss, etc).
A. Dromund Kaas (Kaas City)

Q. Approximate time when the incident occurred.
A. 12/20/2012 around 11pm

I became successfully a subscriber, but he didn't when we activated it at the same time...

Phantom-Hawk's Avatar


Phantom-Hawk
12.31.2012 , 06:29 PM | #117
1. Bladewalker

2. The Shadowlands

3. Voss

4. Logged out on 12/31/2012 at 5:30pm eastern time, logged back in at approx. 6:30pm that same night.


Basically the same issue as the others have posted. I've lost my rested xp (which was about 80,000) and my speeder piloting rank 3. I'm level 49.

Dexen_Rendar's Avatar


Dexen_Rendar
01.14.2013 , 11:00 AM | #118
i subscribed for the first time today but it says im preffered status like before, so nothing has changed, fix it now please i dont want to lose my remaining days because of this.

PsalterFire's Avatar


PsalterFire
01.14.2013 , 11:09 AM | #119
I paid for a 60 day subscription, restarted the game three times, repaired installation, and still I see F2P on my game menu.

1. Thyrkai'aeonos
2. Dalborra.
3. Tython Jedi Temple.
4. 0400 Sydney Time.

chupaDAMINGO's Avatar


chupaDAMINGO
02.06.2013 , 03:08 AM | #120
I am having the same problem. I was F2P and decided to subscribe for two months so i did. I received my cartel coins on SWTOR.com but not in the game. and it still has me as F2P in the game.

Character Name: Malkego
Server Name: The Ebon Hawk, RP, East Coast, Light
Class: Sith Warrior, Juggernot, Kaas
Date: 2/6/13 0930 AM Germany