Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Bought a subscription, now can't play

STAR WARS: The Old Republic > English > Customer Service
Bought a subscription, now can't play
First BioWare Post First BioWare Post

LordoftheNight's Avatar


LordoftheNight
11.17.2012 , 04:11 AM | #71
I am experiencing this problem as well and it's very very annoying.
The Valcoran Legacy (Red Eclipse Server): Xarl - Powertech, Ruhksana - Sorcerer, Uzas - Smuggler, Emmesh-Aiye - Marauder, Asaid - Agent.

LordoftheNight's Avatar


LordoftheNight
11.17.2012 , 04:18 AM | #72
Well someone appears to have done something because I can log in now.
The Valcoran Legacy (Red Eclipse Server): Xarl - Powertech, Ruhksana - Sorcerer, Uzas - Smuggler, Emmesh-Aiye - Marauder, Asaid - Agent.

thyrionnnn's Avatar


thyrionnnn
11.17.2012 , 04:20 AM | #73
Not for me.

Maelphia's Avatar


Maelphia
11.17.2012 , 04:25 AM | #74
is there just a delay between adding a sub plan and being able to log in? my account page here says im a subscriber, but the launcher is telling me no active subscription. weird part is i was playing F2P just fine bout 15 minutes ago......

thyrionnnn's Avatar


thyrionnnn
11.17.2012 , 04:28 AM | #75
If there is a delay it's larger than 4 hours... No, it seems that it's a technical problem.

Alexcuza's Avatar


Alexcuza
11.17.2012 , 04:43 AM | #76
I have tried all the so called "solutions" out there, repairing the launcher, unsetting the remember account etc., nothing worked.

Now I am trying to reinstall the game, but most likely it will be for nothing....

The irony is strong here, you can play for free but if you pay you can't.....someone should make a meme about it

I will update here in case the reinstall has any good results.

Thanks.

prospectorstu's Avatar


prospectorstu
11.17.2012 , 04:51 AM | #77
Yep same here just payed for 3 months and same issue.. good one BioWare

squirrelfish's Avatar


squirrelfish
11.17.2012 , 05:17 AM | #78
Still cannot start game here, spent over 2 hours earlier on the phone and finally got through to a cs rep to which I was then told yes they know this problem and how to fix it so could I please hold while they put me through to a higher tier to remedy this.

Then they cut me off, to say I was annoyed would be an understatement.

Play swtor as preferred: Free
Pay to re-sub: 8.99
Be denied playing and get hung up on when contacting support: priceless

Sarcasm aside though it is really taking the piss, not just the error but the fact that your customer service hangs up on people, really bad form and take that from an ex customer service manager.

yugiwan's Avatar


yugiwan
11.17.2012 , 05:30 AM | #79
cannot play too Hope, it can get fixed for us
Bought a 1-month suscription yesterday - get the "no suscription " message in the launcher

sladescyth's Avatar


sladescyth
11.17.2012 , 05:35 AM | #80
ugh same bought subscription can't play hope every thing gets sorted out soon