Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Bought a subscription, now can't play

STAR WARS: The Old Republic > English > Customer Service
Bought a subscription, now can't play
First BioWare Post First BioWare Post

Peillach's Avatar


Peillach
11.17.2012 , 12:18 AM | #51
I successfully logged in and was greeted by the 'You are now a subscriber' message, am able to create up to 12 characters per server, and am testing the rest of the features right now

Achimrst's Avatar


Achimrst
11.17.2012 , 12:18 AM | #52
Quote: Originally Posted by Peillach View Post
I just got off of the phone with Customer Support, they are moving my ticket up in priority and said they will call me back tonight.

In unrelated news, I can now log in
They just move up your ticket (╯ _)╯︵ ┻━┻ Good thing I never got through!!!

Peillach's Avatar


Peillach
11.17.2012 , 12:21 AM | #53
My account is now credited with cartel coins for my subscription, all action bars are unlocked and available, I can hide my head slot and unify my colors. It seems to be working in game as far as I can tell, but the swtor site still has the 'Add a subscription' checkbox greyed out.

Thank you so much

Airmanorser's Avatar


Airmanorser
11.17.2012 , 12:22 AM | #54
now can play finaly no more error 3001

Achimrst's Avatar


Achimrst
11.17.2012 , 12:24 AM | #55
Weee I can have fun again!
(╯ _)╯︵ ┻━┻ But still no cookies!!!

whiskeytrigger's Avatar


whiskeytrigger
11.17.2012 , 12:24 AM | #56
I am also capable of playing with full subscriber benefits now. Thanks.

Beesodd's Avatar


Beesodd
11.17.2012 , 12:25 AM | #57 Click here to go to the next staff post in this thread. Next  
Phew. Thanks for the updates everyone, and for your patience(and amusing table-flipping) which we worked on it.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Prohteus's Avatar


Prohteus
11.17.2012 , 12:26 AM | #58
Quote: Originally Posted by Beesodd View Post
Phew. Thanks for the updates everyone, and for your patience(and amusing table-flipping) which we worked on it.
I still can't log in from my sub account (CitySushi). Same issue as the folks above, paid for subscription but get the "no active subscription" at launch. I can't post from my sub account either. Had to log into this account just to post about it. Been on hold for one hour waiting for tech support. I'd really like to play!

Zexu's Avatar


Zexu
11.17.2012 , 12:34 AM | #59
Having the same issue. Can I get some help?
"[...] It is the internal struggles, when fought and won on their own, that yield the strongest rewards[...]."
―Kreia to the Jedi Exile

Author of Intergalactic Intel

Host of Galactic Transmission

jorg_isl's Avatar


jorg_isl
11.17.2012 , 12:35 AM | #60
I have the exact same problem as the OP. I am a first time subscriber. Subscription status shows OPEN and my card has been billed. I received 2 welcome email messages. After logging into the game launcher the dreaded "There is currently no active subscription on this account" message comes up.

Very frustrating indeed.