Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Windows 8 problems

First BioWare Post First BioWare Post

optimuslantern's Avatar


optimuslantern
11.18.2012 , 03:10 PM | #11
Anyone?

Amodin's Avatar


Amodin
11.19.2012 , 02:12 AM | #12
Post your DXDIag in a spoiler tag so we can see. You could have some hardware issues, or driver issues going on.

-TheDoctor-'s Avatar


-TheDoctor-
11.19.2012 , 03:07 AM | #13
I'm running Windows 8 Pro 64-bit and have had no problems or any issues running SWTOR. If anything, I find that it runs faster than it did for me on Windows 7.

Current config:
Windows 8 Pro 64-bit with Media Center (RTM)
16 GB (2 x 8 GB) of Patriot Viper 3 PV316G160C9K 1600 (PC3 12800) 16 GB DDR3 RAM / Cas Latency 9
MSI AMD Radeon 7870 GHz Edition / OC Edition with 2 GB DDR5 / PCI Express 3.0
MSI Z77A-G43 motherboard
Intel Core i7 3770K

I can also confirm the game runs fine with the AMD A10-5800K APU and the MSI FM2-A75MA-E35 motherboard with the same memory listed above on the Intel system. My son is running the AMD config listed here, also with Windows 8 Pro x64 (RTM) and he has no technical problems with the game, it runs nice and fast and is very stable.

While I sympathize with the issue you're having, I know others who are running the game just fine on Windows 8 64-bit without any technical problems or issues. I don't think it's Win8. Try updating or re-installing your chipset/motherboard and graphics/audio drivers possibly - that may help. Another option is to re-install the game, though that takes a long time since it's such a big download.
╬╬╬╬╬╬█|{ ██████████████████████████████ )

optimuslantern's Avatar


optimuslantern
11.19.2012 , 08:05 PM | #14
Quote: Originally Posted by -TheDoctor- View Post
I'm running Windows 8 Pro 64-bit and have had no problems or any issues running SWTOR. If anything, I find that it runs faster than it did for me on Windows 7.

Current config:
Windows 8 Pro 64-bit with Media Center (RTM)
16 GB (2 x 8 GB) of Patriot Viper 3 PV316G160C9K 1600 (PC3 12800) 16 GB DDR3 RAM / Cas Latency 9
MSI AMD Radeon 7870 GHz Edition / OC Edition with 2 GB DDR5 / PCI Express 3.0
MSI Z77A-G43 motherboard
Intel Core i7 3770K

I can also confirm the game runs fine with the AMD A10-5800K APU and the MSI FM2-A75MA-E35 motherboard with the same memory listed above on the Intel system. My son is running the AMD config listed here, also with Windows 8 Pro x64 (RTM) and he has no technical problems with the game, it runs nice and fast and is very stable.

While I sympathize with the issue you're having, I know others who are running the game just fine on Windows 8 64-bit without any technical problems or issues. I don't think it's Win8. Try updating or re-installing your chipset/motherboard and graphics/audio drivers possibly - that may help. Another option is to re-install the game, though that takes a long time since it's such a big download.
When I did a search for my problem everything I found was from w8 users and my computer was running every other game fine without the issue.

optimuslantern's Avatar


optimuslantern
11.19.2012 , 08:07 PM | #15
Here's my dxdiag part 1
Spoiler

optimuslantern's Avatar


optimuslantern
11.19.2012 , 08:08 PM | #16
Part two

Spoiler

optimuslantern's Avatar


optimuslantern
11.19.2012 , 08:09 PM | #17
Quote: Originally Posted by Amodin View Post
Post your DXDIag in a spoiler tag so we can see. You could have some hardware issues, or driver issues going on.
Posted.

optimuslantern's Avatar


optimuslantern
11.21.2012 , 10:46 PM | #18
dsffh

campbellsoup's Avatar


campbellsoup
11.26.2012 , 05:59 PM | #19
Running it on windows 7 I have been having issues since 1.5. Not exactly what you described, but my game will just randomly close. It might just be performance issues with 1.5, which I assume they will fix in the first or second patch. Haven't updated my computer I play SWTOR on yet because I wasn't sure about the compatibility, but have updated another computer without many performance issues. I doubt the game will be "compatible" for a few weeks while they get support up to date with windows 8 and work out any bugs.

Amyas's Avatar


Amyas
11.27.2012 , 09:42 AM | #20
My wife is having the same problem on her new PC